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Chapter 1

Preface

Chapter 1

The A PCON ACI-2058 I NTELLAP ATCH ™ physical layer switch enables efficient, cost-saving
management at the foundation of your enterprise network or interoperability test lab—the
physical layer.
With a compact design that saves valuable rack space, the ACI-2058 provides up to 288
ports of any-to-any connectivity at full wire speed. You can populate the 11U chassis with
up to eighteen blades to support a wide array of protocols, including 1, 2, and 4Gb/s Fibre
Channel, Ethernet from 10 Mb/s to 10 Gb/s,T1/E1/J1, DS3/E3/STS-1, SONET/SDH,
and FDDI.

1.1.

About This Manual
This manual assists those who automate, control, and manage networks using the ACI-2058.
This manual assumes you know how to:

1.1.1.

•

Connect and disconnect standard types of cables

•

Use and configure operating systems and networks.

Contents
This manual contains the following:
Chapter/Appendix
1
Preface
2
Introduction
3
Install and Set Up the Switch
4

Connect to a Host

5

Maintaining the Switch

A

Serial Port Pinout

Description
Explains how to use this manual.
Describes features of the ACI-2058.
Explains how to install A PCON software, access an
A PCON switch, and run the software.
Explains how to establish an Ethernet connection
and connect to a host computer.
Explains how to remove and re-install blades,
tranceivers, and power supplies for repair or
upgrade.
Lists and describes each pin of the RS-232
serial port.
Lists product topics for quick reference.

Index
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1.1.2.

Text Conventions
This manual uses the following conventions:
>

Indicates the movement through menu options. For example, the sequence for
changing the switch name is:
Views>Switch Details

MonoText

Indicates information that displays on the screen.

MonoBold

Indicates information you type.

ItalicText Variable parameters.

Note
ESD CAUTION
CAUTION
WARNING
DANGER

1.2.

Indicates important information about the product.
Indicates situations that may cause damage to hardware via ESD
(ElectroStatic Discharge).
Indicates potentially hazardous situations which, if not avoided, may
result in minor or moderate injury, or damage to data or hardware.
It may also alert you about unsafe practices.
Indicates potentially hazardous situations which, if not avoided, can
result in death or serious injury.
Indicates imminently hazardous situations which, if not avoided, will
result in death or serious injury.

Related Products
A PCON provides these software products that you use to access and control your
I NTELLA P ATCH switch(es):
•

WEBX, embedded in the ACI-2058, controls the ACI-2058 remotely from a web browser
over a network or the Internet. For security, you can enable SSL.

•

C ONTROL X, included on the CD that comes with your INTELLAP ATCH switch, provides an
easy-to-use, menu-driven drag-and-drop graphical user interface (GUI) that you use to
operate and reconfigure ports from a host computer running Windows NT, 2000, or XP, or
the Linux or Solaris operating systems.

•

A PCON C MDX provides an interactive Telnet and SSH command line interface.

•

Firmware Direct Commands, embedded in the ACI-2058, control the ACI-2058 using any
scripting language (such as Tcl or Perl) that supports reading from and writing to serial or
socket connections.

•

C/C++ API provides programmatic access to the switch. To acquire this product, contact
A PCON as described in the next section.

Additional software can be purchased for application-specific purposes.

A54-2058-000
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1.3.

Contacting APCON
You can find out more about INTELLAP ATCH products from these sources:
•

Release notes: Lists features and issues that arose too late to include in other
documentation.

•

World Wide Web: A PCON maintains an active site on the World Wide Web. The site
contains current information about the company and locations of sales offices, new and
existing products, contacts for sales, service, and technical support information. You can
also send email to A PCON using the web site.
•

To access the A PCON web site, enter this URL in your web browser:
http://www.apcon.com

•

To contact A PCON technical support, enter this URL in your web browser:
http://www.apcon.com/support

Note
When sending email for technical support, please include information about both
the hardware and software.
•

A54-2058-000

APCON sales representative: If you purchased your product from A PCON , you can contact
your sales representative via email or phone.
Email:

sales1@apcon.com

Telephone:

503-682-4050

Fax:

503-682-4059
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Chapter 2

Introduction

Chapter 2

A PCON ’s ACI-2058 INTELLAP ATCH physical layer switch enables intelligent, flexible control of
your test lab or enterprise network. The physical layer switch cross-connects copper and
optical cables, providing easy-to-use point-to-point, multicast, and loop connectivity across a
nonblocking, full line-rate switching matrix.

2.1.

Features
The ACI-2058 offers the following features:
•

Electronic physical layer switch with up to 288 ports and eighteen blades in an 11U
height

•

Transparent electronic switching

•

Compliant with 1, 2, and 4 GB Fibre Channel, 10 Gigabit Fibre Channel, 10/100/1000
and 10 Gigabit Ethernet, SONET OC-3, OC-12 and OC-48, T1/E1/J1, DS3/E3/STS-1,
and FDDI (blade-specific)

•

Small Form Factor Pluggable (SFP) transceiver module support

•

Signal regeneration (blade-dependent)

•

10 Mbit to 10 Gbit/sec port data rate capability

•

1.26 Tb/sec switching capacity per chassis

•

Connections from 1 meter to 10 Km (fiber optic) and up to 100 meters for copper
Ethernet (blade-specific; fiber optic varies by transceiver)

•

Two LAN ports and two serial ports for remote software execution

•

Windows †, Linux †, and Solaris † support for A PCON C ONTROL X GUI software

•

Support for multi-user sessions

•

Embedded web management software for drag-and-drop patching, SSL included

•

Embedded Telnet command-line interface with SSH client support (uses A PCONCMDX
syntax)

•

Embedded ASCII command set interface (backwards-compatible with custom scripts)

•

Sixteen user-defined preset patching configurations

Each switch can control up to 288 independent fiber optic or copper ports, with the ability to
connect any port to any other port. All ports are fully bi-directional, offering complete
flexibility in determining where to connect host computers, targets, switch ports, or other
network devices. You can configure fiber optic or copper connections remotely to eliminate
manual manipulation of connections.
The ACI-2058 can be externally connected to any AC input voltage between 100 and 240
volts; three hot-swappable AC power supplies provide redundant power to the unit,

A54-2058-000
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auto-ranging input voltages between 90 V AC and 240 V AC. If one power supply fails,
operation is not affected.
The ACI-2058 has two LAN ports that support Ethernet connections and two RS-232 ports
that support the serial interface. You can connect up to 32 I NTELLAP ATCH switches at once
and control them using one serial port, or any number of INTELLAP ATCH switches using one
LAN port.
The physical layer switch has a variety of redundant components to ensure uninterrupted
operation:
•

The switch has three hot-swappable power supplies, only two of which are necessary for
operation.

•

A wide variety of blades (see Blades on page 6) can be installed and removed during
operation.

The ACI-2058 increases the distance capability of each fiber optic connection by
regenerating the optical signal, thereby improving performance and reliability due to reduced
cable and interconnection losses. The ACI-2058 allows standard optical connections to
extend up to various distances, depending on the transceiver module — typically from one
meter to 300–550 meters using multimode transceivers, and up to 10 Km using single-mode
transceivers.
Copper Ethernet connections of 10, 100, or 1000 Mb/second have a signal distance limit of
one hundred meters. The ACI-2058 regenerates these signals as well, so that they can reach
an additional one hundred meters when patched to another device.

A54-2058-000
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2.2.

Specifications
Table 1. Specifications
Item
ACI-2058-C00:
288-port chassis

Serial interface

LAN port

Physical

Agency approvals

2.3.

Number
Number of blade slots
Number of ports
Protocol
Blade data rate
Baud Rate
Mode

Description
Eighteen
Up to 288 (depending on blade type)
Various; see Blades on page 6
10 Mbit to 10Gbit/sec
9600 baud
No parity, 8 bits, 1 stop bit, software
flow control
Maximum cable length
15 meters (50 feet)
Rear panel connectors
DB-9
Protocol
TCP/IP
Interface
10/100/1000 Base-T Ethernet
Rear panel connector
RJ-45
Mechanical
16.75" W x 15.00"D x 18.80"H
(42.5 cm W x 38.1 cm D x 47.8 cm H)
Weight
34 pounds (15.4 kg) without blades or
transceiver modules
Power
100 to 240 V AC 50 / 60 Hz (800 A)
Temperature Operating 0°C to 50°C (32°F to 123°F)
Storage –40°C to 85°C (–40°F to 185°F)
Humidity
0% to 90% RH (noncondensing)
Rack mount
19 inches, 11U
UL, FCC Class A, CE

Blades
The ACI-2058’s modular design enables you to manage multiple protocols and data rates in a
single chassis. You can populate the switch with up toeighteendifferent blades, each blade
having from four to sixteen ports. In addition to one-to-one, one-to-many, and loop
connectivity, blades can provide the following capabilities:
•

Media conversion. Some blades use optical connectors while others use electrical.
Connect a port on a fiber optic blade to a port on a blade using copper connectors and,
dependent on the blade model, the ACI-2058 seamlessly converts signals from one
medium to the other, assuming that the optical and copper blades use the same protocol.
Optical signals can also be converted from multimode (shortwave) to single-mode
(longwave).

A54-2058-000

•

Repeater. Most blades for the ACI-2058 extract the clock from the signal, clean up jitter,
and then add the clock back to the signal.

•

Retimed signals. Certain blades for the ACI-2058 extract the clock from the signal,
clean up jitter, and then add a switch-generated clock back to the signal.
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The specific blades available for the ACI-2058 include:
Model
ACI-2059-B16-1
ACI-2059-E16-2
ACI-2059-E16-1M1
ACI-2059-E16-1M2
ACI-2059-E16-1M3
ACI-2059-E16-1M4
ACI-2059-E16-1M6
ACI-2059-E16-1S1
ACI-2059-E04-3M
ACI-2059-E04-3S
ACI-2059-F16-1C
ACI-2059-F16-1M
ACI-2059-F16-1S
ACI-2059-F16-6M
ACI-2059-F04-3S
ACI-2059-I16-3S1
ACI-2059-I16-3M2
ACI-2059-I16-3S2
ACI-2059-I16-3S3
ACI-2059-M16-1M
ACI-2059-M16-1
ACI-2059-D08-1
ACI-2059-T08-1

Description
Blank cover panel for unused blades
16-port multi-rate, 10/100/1000 Mb/s, copper (RJ-45)
16-port Fast Ethernet, 100 Mb/s, 1310nm multimode optical (LC)
16-port Gigabit Ethernet, 1.25 Gb/s, 850nm multimode optical (LC)
16-port FDDI, 100 Mb/s, 1300nm, multimode optical (LC)
16-port Gigabit Ethernet, 500 Mb/s-1.25 Gb/s, 850nm multimode
optical (LC)
16-port ESCON, 200 Mb/s, 1310nm multimode optical (LC)
16-port Gigabit Ethernet, 1.25 Gb/s, 1310nm single-mode optical (LC)
4-port Ethernet, 10 Gb/s, 850nm multimode optical (LC)
4-port Ethernet, 10 Gb/s, 1310nm single-mode optical (LC)
16-port Fibre Channel, 1 and 2 Gb/s, copper (HSSDC-2)
16-port Fibre Channel, 1 and 2 Gb/s, 850nm multimode optical (LC)
16-port Fibre Channel, 1 and 2 Gb/s, 1310nm single-mode optical (LC)
16-port Fibre Channel, 1, 2 and 4 Gb/s, 850nm multimode optical (LC)
4-port Fibre Channel, 10 Gb/s, 1310nm single-mode optical (LC)
16-port SONET OC-3, 155 Mb/s, 1310nm single-mode optical (LC)
16-port SONET OC-12, 622 Mb/s, 1310nm multimode optical (LC)
16-port SONET OC-12, 622 Mb/s, 1310nm single-mode optical (LC)
16-port SONET OC-3/OC-12/OC-48, Gigabit Ethernet, 1310nm singlemode optical (LC)
16-port multirate, Gigabit Ethernet, Fibre Channel 1 and 2 Gb/s,
850nm, multimode optical (LC)
16-port multirate, 100 Mb/s–3.2 Gb/s (depends on SFPs installed;
contact factory)
8-port DS3/E3/STS-1, 44.7 MHz/34.3 MHz/51.8 MHz copper (miniBNC)
8-port T1/E1/J1, 44.7 MHz/34.3 MHz/51.8 MHz copper (mini-BNC)

Transceiver Modules
Some blades for the ACI-2058 use Small Form Factor Pluggable (SFP) transceiver modules.
SFP modules are available for all supported data rates and protocols, with the following
features:
•

A54-2058-000

SFP module types include:
•

Copper SFP transceivers, available for Fibre Channel (HSSDC-2) and Gigabit
Ethernet (RJ-45).

•

Multimode (MMF) or single-mode (SMF) fiber optic SFP transceivers, available
for Ethernet, Fibre Channel, SONET OC-3, OC-12, OC-48 and FDDI.

•

SFP transceivers have duplex LC fiber optic connections.

•

Each transceiver provides built-in Serial ID capabilities. Use A PCON ’s C ONTROL X or
WEBX to obtain information about the transceiver’s manufacturer, part number, serial
number, revision, date of manufacture, and other module-specific parameters.
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2.4.

•

SFP transceivers used in the ACI-2058 are hot-pluggable, allowing you to change the
transceiver while the unit is operating and under power.

•

You can view SFP transceivers with digital diagnostic support using A PCON ’s C ONTROLX
or WEB X.

Switch labeling
To identify each port, modular switches use the following conventions:
Figure 1. ACI-2058 Port Labeling

Blade and row labels
use letters and start
at the bottom.

Modular (blade) switches

A01

A02

...

Ann

Port labels use numbers prefaced
by blade letter, and start at the left.

Blades have varying numbers of ports, and a chassis may or may not be fully populated with
blades. The greatest number on each blade and the greatest letter in each chassis varies
according to the number of ports in a blade and the number of blades installed in a chassis.
The ACI-2058 refers to ports using these labels. You can use the ACI-2058 to assign names
to your ports, names that indicate devices they connect to or to provide other meaningful aids
to memory.

2.5.

Software
A PCON provides these software products that you can use to access and control your
I NTELLA P ATCH switch(es):

A54-2058-000

•

WEBX, embedded in the ACI-2058, controls the ACI-2058 remotely from a web browser
over a network or the Internet. For security, you can enable SSL.

•

C ONTROL X, included on the CD that comes with your INTELLAP ATCH switch, provides an
easy-to-use, menu-driven drag-and-drop graphical user interface (GUI) that you use to
operate and reconfigure ports from a host computer running Windows NT, 2000, or XP, or
the Linux or Solaris operating systems.

•

A PCON C MDX provides an interactive Telnet and SSH command line interface.
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•

Firmware Direct Commands, embedded in the ACI-2058, control the ACI-2058 using any
scripting language (such as Tcl or Perl) that supports reading from and writing to serial or
socket connections.

•

C/C++ API provides programmatic access to the switch. To acquire this product, contact
A PCON as described in the next section.

Additional software can be purchased for application-specific purposes.
All software interfaces provided for the ACI-2058 include these features, as well as many
others:
•

Patch ports and view port status.

•

Store and recall presets.

•

View power supply status.

•

View the chassis internal temperature, set a temperature threshold for an internal alarm.

•

Configure the serial and LAN ports.

•

On supported blades, set the data rate and duplex settings.

To retain configuration and setup information, the ACI-2058 has internal nonvolatile memory;
port settings and control parameters are saved as they are entered.

A54-2058-000

9

A PCON, Inc.

Chapter

Chapter 3

Install and Set Up the Switch

Chapter 3

To install the ACI-2058, follow these steps:
Figure 2. Installing the Switch
Start

Plan the installation

Unpack the carton
Install the switch
Power up
Set IP Address
Access the Switch

Done

The rest of this chapter details the above steps.
If you experience difficulty during installation, contact your sales office or A PCON Technical
Support. as described in Contacting A PCON on page 3.

3.1.

Plan the Installation
Do this planning before you start installation:

A54-2058-000

•

If you plan to rack-mount the chassis, ensure you have the tools needed to mount the
chassis flanges to the rack.

•

Ensure there is enough power into the rack to support all units you plan to install. For
power requirements, see the Power section in Table 1, “Specifications,” on page 6.

•

Plan how to route fiber-optic and Ethernet cables to the ACI-2058. Also acquire the
cables. The ACI-2058’s fiber-optic connectors are of the LC duplex type.

•

Plan how to meet the chassis’ requirement for air that enters via the left side (as you face
the unit) and exits at the right.
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•

3.2.

Determine what optional software, if any, to use to communicate between the host
computer and the switch. If you plan to use the A PCON C ONTROL X interface, you will need
to install it as described in Install Optional Software on page 13.

Unpack the Carton
Unpack the carton(s) and do the following:
•

Inspect all components for any sign of damage.
Note
• If the shipping carton is damaged or water-stained, please contact the freight carrier
for inspection of carton and contents.
• To return a product damaged in shipment, contact A PCON to obtain a Return
Merchandise Authorization (RMA) number and further instructions.

•

Verify you have the items you ordered. A standard ACI-2058 switch kit includes these
items:
Note
If any modules are in ESD shielding bags, do not yet remove them from the bags.
•

One ACI-2058 INTELLAP ATCH physical layer switch chassis

•

Two rack mount brackets (attached to the chassis)

•

Four bottom “feet” (for tabletop, non-rack mount installations)

•

Three AC power cables (110 or 220 V)
Note
Unless otherwise specified, the ACI-2058 ships with 110-volt power cords. A PCON
offers a complete selection of replacement power cords for most countries.

3.3.

•

One 10 foot RS-232 cable, 9-pin male to 9-pin female

•

One RS-232 adapter, 9-pin male to 25-pin female

•

Blades and transceivers, as ordered

•

One A PCON software CD

•

One I NTELLAP ATCH Product Documentation binder which includes all your
I NTELLAP ATCH documentation, including this guide.

Install the Switch
You can place the ACI-2058 on any stable surface or install it in a standard 19-inch (EIA unit)
rack.
CAUTION
• Ensure that the unit remains within the temperature limits detailed in Specifications on
page 6.
• Place the ACI-2058 in a location that allows adequate airflow to the fans and ventilation
slots on the sides of the unit.
• Do not place the ACI-2058 on any device that generates excessive heat.

A54-2058-000
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3.3.1.

Rack Installation
The ACI-2058 ships with rack mount flanges attached. To install the switch in a rack:
1.

Set the unit into position on the rack, aligning the mounting bracket holes with the
rack holes.

2.

Install the chassis in the rack, securing the chassis with the appropriate screws.
Note
If the switch is installed in a rack with other equipment, ensure that you don’t overload
the wiring circuits. In all cases, make sure power strips and wall sockets are grounded.

3.3.2.

Table Top Installation
The ACI-2058 ships with “feet” for installation on a flat surface, such as a workbench. To
attach the “feet” to the switch:
1.

Remove the backing from a “foot”.

2.

Attach the “foot” to a bottom corner of the switch.

Repeat these steps for each of the four “feet.”

3.3.3.

Install Blades and Transceivers
The ACI-2058 typically ships with all blades and transceivers installed. If they are not
installed or if you need to move them, see Blades on page 20 or Transceiver Modules on
page 21.

3.4.

Power Up
1.

Turn on the ACI-2058’s three AC power switches, located on the rear panel.

2.

Verify each power supply’s operation by checking the LEDs:
Table 2. LED Operation
LED state

Description

Power LED lit

The power supply is functioning normally.

Fault LED lit

The power supply is not functioning.

Power and Fault LEDs off

The power supply is not functioning.

Threehot-swappable AC power supplies provide redundant power to the unit. If one power
supply fails, operation is not affected; however, an alarm sounds and that supply’s fault LED
lights. This alarm can be turned off using any of the software interfaces; for instructions, see
the specific software manual.

A54-2058-000
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Figure 3. ACI-2058 Rear Panel

3.5.

Set the IP Address
For details, see Setting the IP Address on page 14.

3.6.

Access the Switch

3.6.1.

Use Embedded Software
The following software is embedded in your ACI-2058 switch. These applications are
immediately available for use without reconfiguration or installation:
•

WEBX, an embedded web interface.

•

APCONC MDX, a command line interface.

•

Firmware Direct Commands, ASCII programmatic access.

For usage details, see the appropriate software User Manual.

3.6.2.

Install Optional Software
To communicate with the switch from a host computer, you can use C ONTROLX, included on
the CD-ROM that comes with the ACI-2058. To use C ONTROLX, install it on the host computer
you plan to use to control the ACI-2058:
1.

Insert the CD into the host computer, or download the latest version from the A PCON
website:
http://www.apcon.com

2.

Follow the onscreen prompts.

You are now ready to connect the ACI-2058 to a host. For details, see Chapter 4, Connect to a
Host.

A54-2058-000
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Connect to a Host

Chapter 4

To operate the ACI-2058, you must connect the unit to a host computer running a Windows,
Linux, or Solaris operating system. Once connected, you can use one or more of these to
control the switch:
•

WEBX (using standard HTTP or SSL)

•

C ONTROL X (requires installation, as described in Install Optional Software on page 13)

•

A PCON C MDX, which you can access via Telnet or SSH.

•

Firmware Direct Commands

To use C ONTROL X, WEBX, or APCON C MDX, you must establish an Ethernet connection. This
chapter explains how.
For information about...
Go to this page...
Overview ...................................................................................................................... 14
Setting the IP Address ................................................................................................... 14
Connecting Multiple Switches ......................................................................................... 17
Connecting Multiple Switches with Serial Ports ............................................................ 17
Connecting Multiple Switches with LAN Ports ...................................................................... 19

4.1.

Overview
You can control the ACI-2058 using one of these methods:
•

Ethernet connection running TCP/IP: The ACI-2058 includes two 10/100/1000
Ethernet LAN ports.To use this method, you must assign the switch a static IP address
appropriate for your network.

•

Serial connection: Two RS-232 serial ports. To use this method with either custom
scripts or C ONTROLX, you do not need to set the IP address and other TCP/IP properties.

If desired, you can connect the ACI-2058 to multiple hosts, using any combination of a two
serial or two Ethernet ports.

4.2.

Setting the IP Address
By default, I NTELLAP ATCH switches are shipped with an IP address of 192.168.0.1, a subnet
mask of 255.255.255.0, and no gateway. If it’s convenient to configure your host computer
with an IP address of the form 192.168.0.x (where x is any number from 2 to 254, inclusive),
then the ACI-2058 is immediately available.
If not, then, to use the Ethernet connection, you must change this default IP address to one
appropriate for your network.

A54-2058-000
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You can set the IP address in a variety of ways; these instructions show you how to set the
address using WEBX.
Note
If you plan to use more than one I NTELLAP ATCH switch on your network, configure them at
the same time. This avoids repeated temporary disconnections of the host computer from
your network.
To configure the IP address, subnet mask, and gateway:
1.

Ensure that you have the following:
•

A web browser that supports Javascript including, but not limited to:
•

Firefox † browser, version 1.x or later

•

Internet Explorer, version 6.x or later

•

Netscape† browser, version 7.x or later (the WEBX Interface is not compatible
with version 4.x)

•

Opera

•

Safari† browser
Note
Ensure that your browser’s Javascript is enabled.

2.

•

A host computer that runs one of the above web browsers. The host computer’s web
browser accesses the interfaces embedded in the ACI-2058.

•

An Ethernet connection between the host computer and the switch.

•

An IP address, subnet mask, and gateway (if required) appropriate for your network
to assign to the switch.

Connect a host computer to the ACI-2058:
A. Quit all network client applications currently running on the host computer.
B. Disconnect from your network the host computer you plan to use to assign the
IP address.
C. Plug the host computer’s cable into one of the Ethernet ports on the back of the
I NTELLAP ATCH switch using either a standard patch cable or a crossover cable.
The host and switch are now physically connected.

3.

Enable communication between the host computer and switch.
A. Access the host computer’s current network settings according to the instructions
provided with the host’s operating system. Note them so that you can restore them at
the end of this process.
B. Temporarily change the host settings to the following:
•

IP address:
192.168.0. x
( x is any number from 2 to 254, inclusive)

•

Subnet mask:

255. 255. 255. 0

•

Gateway setting:

0. 0. 0. 0 or blank

The host and switch are now on the same network and can communicate.

A54-2058-000
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4.

Access the switch’s WEBX Interface.
A. On the host computer, open a web browser.
B. If the host computer is configured to use a proxy server, disable the proxy setting.
C. In the browser’s address field, enter:
http://192.168.0.1

D. Click the Edit link, located to the right of the IP Address field. The Configure Network
Interface screen displays:
Figure 4. Configure Network Interface screen

5.

Change the IP address:
A. Type the new IP address, subnet mask (if required), and gateway (if required) in the
fields provided.
Note
The subnet mask assigned to the switch must match the host computer’s
subnet mask.

A54-2058-000
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B. Click the Change button. The switch reroutes the browser to the new address.
C. Exit the browser.
6.

Reconnect the host computer to your network.
A. Reset the host computer’s IP address, subnet mask, and gateway settings to their
original values.
B. Re-cable the host to the network.
C. Ensure that the switch is cabled to the network with a standard Ethernet patch cable.

You can now configure the ports as desired, using the software interface of your choice, and
begin using the switch.

4.3.

Connecting Multiple Switches
You can configure the serial ports to operate as daisy-chained ports. Daisy-chaining switches
allows one computer or terminal to communicate with up to 32 I NTELLAP ATCH switches.
You can use the LAN ports to connect any number of switches without using a hub or wall
jack.You cannot, however, mix serial and LAN port connections in a single chain.

4.3.1.

Connecting Multiple Switches with Serial Ports
C ONTROL X recognizes from 1 to 32 I NTELLAP ATCH switches when daisy-chained. If you plan to
use multiple switches daisy-chained together, you must first assign a unique device number
to each switch. To do so:
1.

Connect the second switch to the host computer using the switch’s COM1 port and a
standard 9-pin straight-through serial cable. (The first switch already has its device
number set to 1 by default.)

2.

On the host computer, start CONTROL X.

3.

Select File>Connect. The Login dialog displays:
Figure 5. CONTROLX Login Dialog

A54-2058-000

4.

Click the Serial Connection radio button. Leave the field set to 1 for the COM1 port
(or change to the specific COM port number of your workstation).

5.

Click the OK button.
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6.

Click the Switch Properties tab.
Figure 6. Switch Properties

7.

Click Communications in the Property List.
Figure 7. Communications Fields

8.

Type 2 in the Device Number field.

9.

Click the OK button to save the setting.

10. Click the OK button to exit the Switch Properties tab.
11. Exit C ONTROL X.
12. Un-cable the switch and cable the host computer to the next switch.
13. Following this procedure, set the next Device Number to 3.

A54-2058-000
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14. Repeat the last two steps until all the switches that you wish to daisy-chain have a
unique device number between 1 and 32.
With unique device numbers, you can now daisy-chain the switches:
1.

2.

3.

4.3.2.

Connect the host computer’s COM
port to the COM1 port on the first
switch (device number 1) using a
standard 9-pin straight-through
serial cable.
Connect the COM2 port on switch 1
to the COM1 port on the switch
having the device number 2.
Connect the COM2 port on switch 2 to the
next switch, and so on until the last switch
is connected. The last switch’s COM2 port
remains unconnected.

Switch 1
COM

1

1
COM 2
COM

COM

1

COM

2

Switch 2

Switch 3
1
COM 2

COM

Connecting Multiple Switches with LAN Ports
To connect more than one switch using LAN ports:
1.

Assign each device a unique IP address. (For details on how to do this, see Setting the IP
Address on page 14.

2.

Connect the host computer to one of the first switch’s LAN ports (using either an
Ethernet crossover cable or a straight Ethernet cable) or connect the first I NTELLAP ATCH
switch to an Ethernet hub or switch connected to your network.

3.

Connect the first switch’s unused LAN port to either of the next switch’s LAN ports with
an Ethernet cable (either kind), or connect the next switch to the network hub.

4.

Repeat step 3 until all switches are connected.

You can now configure the ports as desired, using the software interface of your choice, and
begin using the switch.

A54-2058-000
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Maintaining the Switch

Chapter 5

Occasionally you will want to perform maintenance or upgrades on the ACI-2058 or its
blades. When this occurs, you may need to do one or more of the following:

5.1.

•

Blades: Remove a blade from the chassis, repair or install the desired option, then reinstall the blade. For details, see page 20.

•

Transceiver Modules: Remove or re-locate transceivers, disconnect and reconnect the
cable. For details, see page 21.

•

Power Supplies: Remove a power supply from the chassis, repair or install the desired
option, then re-install the power supply. For details, see page 22.

Blades
The ACI-2058 allows you to install and remove blades, transceivers, and power supplies
without turning the power off to the I NTELLAP ATCH switch itself, though you must turn power
off to the appropriate blade slot before removing or installing a blade.

5.1.1.

Removing Blades
To remove a blade:
1.

Using the software, turn off power to the blade.

2.

Unscrew the thumbscrews on either side of the blade.

3.

Holding the blade straight, gently pull it towards you.
Figure 8. Removing a Blade

Thumbscrew

5.1.2.

Thumbscrew

Installing Blades
To insert a blade:

A54-2058-000

1.

Using the software, ensure that power is off to the slot in which the blade will be
installed.

2.

Hold the blade by its outer edges in front of the target slot.
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3.

Insert the back of the blade into the guides on each side of the slot.

4.

Holding the blade straight, slide it into the guides as far as it will go.
Figure 9. Inserting a Blade

Guide

Guide

Thumbscrew

Thumbscrew

5.

Press the blade into the chassis as you turn the thumbscrews to secure the blade
in place.

The ACI-2058 automatically detects that the blade is in place and powers on the blade.

5.2.

Transceiver Modules

5.2.1.

Removing SFP Transceiver Modules
To remove a transceiver module:

5.2.2.

•

Nonbail type:
Carefully push the ejector pin in while pulling out the module.

•

Bail type:
Pull the bail down and pull out the module.

Installing SFP Transceiver Modules
To insert a transceiver module:
•

•

5.2.3.

Nonbail type:
1.

Hold the module by the housing, so that the label faces up.

2.

Insert the module into the socket until you hear or feel a slight click.

Bail type:
1.

Close the bail latch if it is currently open.

2.

Hold the module by the housing, so that the label faces up.

3.

Insert the module into the socket until you hear or feel a slight click.

Handling and Installing Fiber Optic Cables
To extend the life of transceiver modules, use caution when handling and installing cables.
Do not remove the dust cover until immediately prior to mating the cable. To ensure proper
cable mating, complete the steps in the following procedures.

A54-2058-000
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5.2.3.1.

Disconnecting the Cable
To disconnect the cable:

5.2.3.2.

1.

Grasp the connector while squeezing the connector housing and disconnect the
connector from the unit.

2.

Cover connector ends and SFP transceivers with clean dust caps when not in use.

Connecting the Cable
Clean the cable before connecting it:
1.

Thoroughly wipe the side and end of the ferrule using a lint-free, alcohol-dampened cloth.

2.

Blow dry the ferrule with compressed air.

3.

Visually inspect the ferrule for lint, and blow-dry it again if necessary.

4.

Connect the cable.
Note
• After every demating cycle, clean and blow-dry the ferrule before remating.
• Do not interchange connectors from one unit to another unit without first cleaning the
connector. Doing so can damage the product by transferring small particles to the
transceiver.

5.3.

Power Supplies

5.3.1.

Removing a Power Supply
To remove a power supply:

A54-2058-000

1.

Remove the screw from the latch.

2.

Remove the two screws — one each from the top and bottom left and right latches.

3.

Press the red buttons on the latches in while pushing the latches outward — the upper
one upwards and the lower one downwards.

4.

Push the latches outward.
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5.

Pull the supply toward you.
Figure 10. Removing a ACI-2058 Power Supply

Red buttons

Latch

5.3.2.

Installing a Power Supply
To insert a power supply:

5.3.3.

1.

Make sure the latches are is in the outward position — the upper one pushed into the up
position and the lower one pushed into the down position.

2.

Push the power supply in firmly until you hear the latches click.

3.

Secure (turn) the two screws inside the latch areas (one per latch).

Switch Defaults
The ACI-2058 default configuration as shipped from the factory is:
Table 3. Factory Configuration
Setting
Ports
Serial ports
LAN ports
Device number
Temperature alarm
IP address
Subnet mask
Gateway
Administrator username
Administrator password

Default value
All off
9600 baud, 8 data bits, no parity, 1 stop bit, software flow control
10/100/1000 Ethernet, TCP/IP, both enabled
01
50° Celsius
192.168.0.1
255.255.255.0
none
admin
secret

If the switch exceeds the set temperature limit (by default, 50° C), an alarm sounds. This
alarm can be turned off using any of the software interfaces; for instructions, see the specific
software manual.
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Appendix A

The ACI-2058 contains two RS-232 serial ports, each using a DB9 connector. The
connectors are compatible with standard RS-232 straight-through serial cables. The next
table describes each pin.
Table 4. Serial Port Pinout
Pin
1
2
3
4
5
6
7
8
9

A54-2058-000

Host computer
DCD input
Receive data input
Transmit data output
DTR Output
Ground
DSR input
RTS output
CTS input
RI input

COM1
DCD output
Transmit data output
Receive data input
Connected to pin 8
Ground
DSR output
No connection
Connected to pin 4
No connection
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COM2
No connection
Receive data input
Transmit data output
Connected to pin 8
Ground
No connection
No connection
Connected to pin 4
No connection
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G

password, default 23.
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installing a power supply 23.
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DB9 connector 6.
properties 6.
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Chapter 1

Preface
1.1.

Chapter 1

About WEBX
This manual describes APCON’s WEBX, an embedded web interface that you use to control
your INTELLAPATCH™ switch remotely from a web browser over a network or the Internet.
You can operate WEBX with or without security, and you can control user access to various
WEBX features.
Since WEBX is embedded on the INTELLAPATCH motherboard, no installation is required. To
access the software, you first install your APCON switch, then start a web browser and access
WEBX by entering the switch’s IP address. For details about accessing the WEBX, see
Chapter 3, Setting Up and Accessing the Switch on page 16.

1.1.1.

New in This Release
This version of WEBX includes the following new features:
•

New graphical interface: WEBX now includes Basic menus that you use to provide
detailed information when selecting WEBX features, and Power User menus to use when
you are familiar with WEBX features. Customizable menu toolbars provides quick access
to frequently used WEBX features, and the new menu structure organizes WEBX features
by tasks you routinely perform.

•

TACACS+ support: WEBX now includes support forTACACS+ servers.

•

SNMP: WEBX now includes support for SNMP.

•

Logged-in user display: The new Logged In screen (page 84) displays users currently
logged in to the switch.

•

Adjustable web session timeouts

•

Password strength rules

•

TBD syslog

APCON’s version 2.5 firmware includes the following features:
•

A54-3000-100 A

Ability to switch between the following:
•

CLI version 3 (with CLI v2 for backward compatibility with existing scripts). This
version provides a more easily parsed mode for new scripts and features and now
supports most CLI2 commands.

•

CLI version 2. This version provides a different and less-featured command structure
that is backwards compatible with previous versions of APCONCMDX.
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Chapter 1: Preface

About This Book
The purpose of this manual is to assist anyone who performs these functions related to the
software:

1.2.1.

•

Patches ports using WEBX. This also requires that you know how to connect and
disconnect standard types of cables

•

Configures the switch using WEBX. This also requires that you know how to use and
configure operating systems and networks.

Contents
This manual contains the following chapters and appendices:
Chapter/Appendix
Preface
1
Introducing WEBX
2
Setting Up and Accessing
3
the Switch
Connections
4
5

MONITOR

6

Ports/Blades

7

View

8

Tools

9

Maintenance

10

Settings

11

Help

A

Data File Formats

Description
Explains how to use this manual.
Describes features of WEBX.
Describes how to connect to, log in, and log off the
INTELLAPATCH switch.
Describes screens available from the Connections
menu, where you configure patch settings.
Describes screens available from the MONITOR
menu, which you use to connect to and control any
INTELLAPATCH switch using the PC’s serial port or
TCP/IP LAN connection. You use MONITOR for nonintrusive network monitoring and to sharing
equipment.
Describes screens available from the Ports/Blades
menu, where you configure ports and blades in
your INTELLAPATCH switch.
Describes screens available from the View menu,
where you can access switch information and
network status.
Describes screens available from the Tools menu,
where you can run diagnostic tests.
Describes screens available from the Maintenance
menu, where you can update or restore
configuration files.
Describes screens available from the Settings
menu, where you can manage user access and
switch security.
Describes screens available from the Help menu,
where youcan find information about your
INTELLAPATCH switch and contacting APCON.
Provides samples for system log files and
import/export files.
Lists product topics for quick reference.

Index
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Text Conventions
This manual uses the following conventions:
>

Indicates the movement through menu options. For example, the
sequence for changing the switch name is:
View>Chassis>Controller Status

bold

Indicates a directory or a file.

MonoText

Indicates information that displays on the screen.

MonoBold

Indicates information you type.

ItalicText

Variable parameters.

Note
CAUTION
WARNING
DANGER

1.3.

Indicates important information about the product.
Indicates potentially hazardous situations which, if not avoided, may
result in minor or moderate injury, or damage to data or hardware. It may
also alert you about unsafe practices.
Indicates potentially hazardous situations which, if not avoided, can
result in death or serious injury.
Indicates imminently hazardous situations which, if not avoided, will
result in death or serious injury.

Related Products
INTELLAPATCH Switches
APCON INTELLAPATCH switches employ
a modular chassis/blade design that
work with a variety of protocols and
data rates.
With this modular system, you can
populate each switch chassis with
different blades, deploying Ethernet,
SONET, Fibre Channel and other
blades in a single chassis, while
running every blade independently and simultaneously. This modular design also provides
cost-effective media conversion and scalability.
APCON’s WEBX is compatible with high-density (1") INTELLAPATCH switches such as these:

A54-3000-100 A

•

INTELLAPATCH ACI-2065:A 1u1 switch with one blade slot that supports up to 16 ports.

•

INTELLAPATCH ACI-2069:A 2u switch with two blade slots that supports up to 32 ports.

•

INTELLAPATCH ACI-2061: A 3u switch with four blade slots that supports up to 64 ports.

•

INTELLAPATCH ACI-2064: A 6u switch with nine blade slots that supports up to 144 ports.

•

INTELLAPATCH ACI-2058: An 11u switch with eighteen blade slots that supports up to
288 ports.

1.

A “u” (unit) is 1.75" or 44mm.
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APCON also provides these software products that you use to access and control your
INTELLAPATCH switch(es):
•

APCONCMDX, included on the CD that comes with your INTELLAPATCH switch, is a
Command Line Utility (CLU) that provides an interactive command line interface.

•

Command Line Utility (CLU) that provides an interactive command line interface.

•

MONITOR, included on the CD that comes with your INTELLAPATCH switch, connects to and
controls any APCON INTELLAPATCH Physical Layer Switch using the PC’s serial port or
TCP/IP LAN connection. This software provides non-intrusive network monitoring and for
sharing of equipment such as traffic analyzers, network probes and Intrusion Detection
System (IDS) equipment.
Some MONITOR features are available in WEBX. For details, see Chapter 5, MONITOR,
starting on page 48.

•

Firmware Direct Commands (ASCII), embedded in your INTELLAPATCH switch, control the
switch using any scripting language (such as Tcl or Perl) that supports reading from and
writing to serial or socket connections.

•

C/C++ API, purchased separately, provides programmatic access to the switch. To
acquire this product, contact APCON as described in the next section.

Additional software can be purchased for application-specific purposes.

1.4.

Contacting APCON
You can find out more about INTELLAPATCH products from these sources:
•

World Wide Web: APCON maintains an active site on the World Wide Web. The site
contains current information about the company and locations of sales offices, new and
existing products, contacts for sales, service, and technical support information. You can
also send email to APCON using the web site.
•

To access the APCON web site, enter this URL in your web browser:
http://www.apcon.com

•

To contact APCON technical support, enter this URL in your web browser:
http://www.apcon.com/support

Note
When sending email for technical support, please include information about both
the hardware and software.
•
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APCON sales representative: If you purchased your product from APCON, you can contact
your sales representative via email or phone.
Email:

sales1@apcon.com

Telephone:

503-682-4050

Fax:

503-682-4059

4

APCON, Inc.

Introducing WEBX

Chapter 2

Introducing WEBX

Chapter 2

This chapter describes the following WEBX features:
For information about...
Go to this page...
Screen Layout ................................................................................................................. 6
Menus ......................................................................................................................... 7
Canvas ....................................................................................................................... 8
Status Bar ................................................................................................................... 8
Navigation ....................................................................................................................... 8
Mouse Techniques ....................................................................................................... 8
Terminology ................................................................................................................. 8
Switch Labeling ............................................................................................................... 9
Patching Ports ................................................................................................................. 9
Assigning IP Addresses .................................................................................................. 10
User Database Concepts ................................................................................................ 11
Network User Authentication ........................................................................................... 12
Simplex Patching with SPAN/Monitor Ports ....................................................................... 13
Disabling Simplex Patching with SPAN/Monitor Ports ..................................................... 15
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Screen Layout
WEBX provides access to the INTELLAPATCH switch through your web browser. The interface
provides the easy-to-use features described in the following sections:
Figure 1. The WEBX interface

Logout

Toolbar

Menus

Canvas

Status bar

2.1.1.

Toolbar
The toolbar povides quick access to WEBX features you frequently use. The toolbar’s
appearance varies, depending on the menu you use:
Basic:

Power user

Note: The toolbars above display the default
factory configuration.

Clicking the arrow minimizes the Toolbar to provide more room for the Canvas, or maximizes
the Toolbar to allow access to its options.
To customize the toolbar, click the arrow at the right side of the menu or select
Settings>Personalization>Your Preferences. For information about setting preferences on
this screen, see Your Preferences on page 105.
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Logout
Note
Logout links display only when the User Database (page 107) is not set to None.
The logout link displays at the far right, where you can click to log out and re-display the login
screen. Another logout link displays in the Status bar, at the screen’s lower right.
The name you specified for the switch also displays to the toolbar’s right; you can change
this name in View>Chassis>Controller.

2.1.3.

Menus
WEBX provides these menus to access features:
Basic
Ribbon

Power User

•

Basic: Displays available options with icons. After selecting an option, you can minimize
the menu by clicking the downward arrow in Switch Info. Use this mode to provide
detailed information you can use to select the appropriate WEBX feature.

•

Power User: Displays available options in a pull-down menu. Use this mode when you
are familiar with WEBX features.

Both Menu and Ribbon modes include the following:
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•

Connections: Display switch status or current settings.

•

MONITOR: Patch using the WEBX MONITOR interface. Only available (visible) with the
proper license key. For information about keys, see License Key on page 98.

•

Ports/Blades: Set and change switch functionality. Most options in this category require
that you log in with Advanced Operator privileges. For information about access
privileges, see Permissions on page 112.

•

View: Displays switch status or current settings.

•

Tools: Displays data and runs tests that you can use to troubleshoot connected devices.

•

Maintenance: Transfer switch settings and store data.

•

Settings: Manage switch and user options. Options on this menu are largely one-time
setup and configuration tasks, and require administrator privileges.

•

Help: Provides information about the switch and how to contact APCON for
more information.
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Canvas
You use the Canvas to view switch settings or configure switch behavior. The screens and
fields that display on the Canvas vary, depending upon the option you select from the menus.
The remainder of this book explains the screens and fields that display on the Canvas, and
the values you can enter in each field.

2.1.5.

Status Bar
The status bar, located at the bottom of the screen, displays the following WEBX information:
Alarm status

Chassis model

Chassis serial number

WEBX c opyright info

Version

Current user

Logout link

Note
The user name and logout link displays only when the User Database (page 107) is not set
to None.

2.2.

Navigation

2.2.1.

Mouse Techniques
You do much of your work in the WEBX using your mouse:

2.2.2.

•

You position your cursor by moving the mouse until the tip of the cursor touches an
object.

•

You hover by positioning the cursor and keeping the cursor in that location.

•

You click by positioning the cursor, then pressing and quickly releasing the left mouse
button once. In this manual, the words click, highlight, and select all mean the same
thing.

Terminology
The instructions in this manual use the terms “enter” and “type” to mean different things.
When the instructions tell you to enter something, you press the appropriate keys and press
the Enter key. When the instructions tell you to type something, you press the appropriate
keys, but do not press the Enter key.

A54-3000-100 A
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Switch Labeling
To identify each port, INTELLAPATCH switches use the following port labeling conventions:
Figure 2. Switch labeling

Blade labels use
letters and start
at the bottom

A01

A02

...

Ann

nn is an integer
from 01 to 16

Port labels use numbers prefaced by
blade letter, and start at the left.

Blades have varying numbers of ports, and a chassis may not be fully populated with blades.
The greatest number on each blade and the greatest letter in each chassis varies, therefore,
according to the number of ports in a blade and the number of blades installed in a chassis.
WEBX refers to ports using these labels. You can use the WEBX to assign names to your
ports, names that indicate devices they connect to or to provide other meaningful aids to
memory. For details, see Port Properties on page 50.

2.4.

Patching Ports
APCON’s WEBX features the following methods to patch ports:
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•

Interactive patching: Patch ports interactively using a graphical, click-and-drop interface.
For details, see Realtime on page 33.

•

Batch operations: Create a patching configuration for the entire switch at once and then
have this configuration take effect all at the same time. For details, see Realtime on
page 33.

•

Quick patching: Type in one or more port names, or select from a dropdown list, to make
a few quick patches. For details, see By Name on page 42.

•

Preset configurations: Patch ports according to a preset configuration. For details, see
By Preset (Presets) on page 45.

•

Import configuration settings: Patch ports according to settings you exported from
another INTELLAPATCH switch. For details, see Restore Settings on page 97.
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Assigning IP Addresses
When you specify only one IP address, that address is assigned to both ports and traffic
flows between the two ports. The ports act like a network switch and you can stack multiple
chassis together, plug one into the network, and daisy-chain the rest.
With two IP addresses, each LAN port is multihomed with the two IP addresses. This means
you can reach each port by either IP address. The two LAN ports on the back of the unit are
split into isolated VLAN segments and cannot pass traffic between each other. You cannot
daisy chain.
Figure 3. Single vs. multiple IP addresses
LAN 2

LAN 1

LAN 2

IP address A IP address A IP address A

IP address A
IP address B

LAN 1

IP address B
IP address A

In the multiple IP address scenario, typically each address is a different subnet. Each LAN
port plugs into the network segment containing that particular subnet. (Since each port
listens for both IP addresses, it doesn’t matter which port gets plugged into which subnet.) In
theory, both IP addresses are available on both LAN ports but, in practice, each LAN port
uses only one address.
Figure 4. Example: multiple IP addresses and subnets

LAN 2

10.1

10.1.n.n
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10.1.n.n

LAN 1

10.2

10.2.n.n
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User Database Concepts
WEBX provides the tools you need to specify the default permission, or access level, for new
user accounts. You can configure or modify user accounts for access at any of these levels:
•

Guest: Users with this permission level have read-only access. This is the lowest
permission level.

•

Operator: Users with this permission level can do all that Guest-level users can do, plus
patch ports using only preset configurations.

•

Advanced Operator: Users with this permission level can do all that Operator-level users
can do, plus patch ports on an ad-hoc basis, change rates and port names, plus save
configuration settings (“presets”).

•

Administrator: Users with this permission level do everything that the other levels do,
plus set switch, blade, port, and other information as well as set and clear user and
security information. This is the highest permission level.

WEBX sends user access information to the Preferences Security database in your
INTELLAPATCH switch.
With the flexible architecture of the user database, you can select any one of these
approaches to store user or access names:
Figure 5. User Database Architecture
• RADIUS or TACACS+ server: This option
RADIUS or
points to the user names stored on a
TACACS+ server
RADIUS or TACACS+ server. This option
works in conjunction with the local User
Security
Database. If a user exists in both
attributes
databases, the local database takes
precedence.
•

Internal user database: This option stores
user names and access information within
the switch. This database includes
an admin account, which acts as a local
administrator.

WEBX
Security
attributes
Logic

INTELLAPATCH switches support up to three different RADIUS or TACACS+ servers for user
authentication. WEBX consults them in a failover sequence. The first server is always
consulted first and is considered the primary server. If no response, the second is consulted,
and so on. If the primary is down, this could lead to longer login times.

A54-3000-100 A
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Network User Authentication
RADIUS and TACACS+ provide centralized user authorization tools. Setting up these
services is outside the scope of WEBX documentation. However, you will find brief
examples here:
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•

RADIUS: For details, see Appendix B, Adding APCON Attributes to your RADIUS Server.

•

TACACS+: For details, see Appendix C, Configuring the TACACS+ Server.
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Simplex Patching with SPAN/Monitor Ports
Note
APCON’s MONITOR feature provides the tools to quickly perform this task. MONITOR requires a
license key, available from APCON. For details about acquiring MONITOR, contact your APCON
sales representative as described in Contacting APCON on page 4 or on the Help>Support
menu option. For information about license keys, see License Key on page 98..
WEBX accommodates simplex patching from SPAN ports to analyzers for enterprises that
require this level of security. When using only simplex patching with SPAN ports, you must
set up your INTELLAPATCH switch as described in this section.
Note
This method requires an APCON Security blade, such as the
ACI-2059-S15-2 or ACI-2059-S15-4. Security blades ensure that
ports connected and defined as SPAN ports only transmit
information. For information about acquiring such a blade, contact
APCON as described in Contacting APCON on page 4.

Figure 6. Security
symbol

(Identifies Security blades)

To configure Security blade ports for simplex patching:
Note
If the WEBX MONITOR feature is activated, as described in License Key on page 98, the
MONITOR Setup wizard automatically performs all these steps. For information about the
wizard, see the MONITOR User Manual.
1.

Configure the automatic transmitter:
A. Select Ports/Blades>Ports>Properties. The Properties screen displays.
B. Select TX on when no RX from the drop-down list.
C. Click the Update button.

2.

Enable port classes:
To create the port classes needed to implement SPAN security, you must configure the
switch to allow port classes.
A. Select Ports/Blades>Configuration>Classes. The Classes screen displays.
B. Ensure that the Enforce Port Classes checkbox, located at the top of the screen, is
checked. When checked, all available port classes display.

3.

Create port classes:
A. Set up these port classes on the Classes screen:
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•

Analyzers: Enter any name that consists of up to 31 characters, including
letters, numbers, spaces, and most keyboard characters.

•

SPAN ports: This class name must begin with the letters “SPAN”; the beginning
of the name is not case-sensitive. For example, SPAN, SPAN Ports, and
SPAN-Lab 1 are valid; Lab 1 SPAN is not. WEBX automatically converts entries
of SPAN or SPAN PORT to SPAN.
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Note: The SPAN port symbol, which replaces
the port number, identifies ports assigned to the
SPAN class. The arrow indicates that the port
can transmit signal; the shield indicates that the
port cannot receive signal. This prevents
accidental network flooding by blocking inbound
traffic on the SPAN port.

Figure 7. SPAN port symbol
Transmit Receive

B. Set each class to Exclusive.
C. Save these classes by clicking the Save button.
4.

Assign ports to classes:
A. Click the Class Members link, located at the top of the screen. The Class Members
screen displays.
B. Assign ports to classes as shown in the next table.
Class
SPAN ports
Analyzers

Comments
Assign to this class only ports used as SPAN ports.
Assign to this class ports that attach to analyzers.

Set port rates

5.

Set port rates:
Note: To ensure proper operation, you must set SPAN and analyzer ports to
specific rates.
A. Select Ports/Blades>Ports>Rates. The Rates screen displays.
B. Set ports you plan to use as SPAN ports to a specific rate in Analyzer Tap mode.
C. Set ports you plan to use as analyzer ports to the specific rate in Analyzer Tap mode.
D. Click the Save button.

6.

Set rate options:
A. Select Ports/Blades>Ports>Properties. The Properties screen displays.
B. (Optional) Check this box to enable passthrough negotiation on the specified blade:
ACI-2052-E16-2 passthrough negotiation
Note: Check only if you set any analyzer ports to Analyzer Tap: Auto.
APCON recommends using a specific data rate.
APCON also recommends enabling these options:
ACI-2052-E16-2 always negotiate
ACI-2052-E16-2 always on
Note: WEBX automatically enables Automatic SPAN Security when you insert
a Security blade.
C. Click the Update button.

You have now set up your SPAN ports, configured the switch for simplex-only connections,
and can patch SPAN ports to an analyzer.

A54-3000-100 A
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Disabling Simplex Patching with SPAN/Monitor Ports
Do any of these:
•

Remove the APCON Security blade(s) from the INTELLAPATCH switch. For details, see your
INTELLAPATCH switch user manual.

•

Disable port classes:
A. Select Ports/Blades>Configuration>Classes. The Classes screen displays.
B. Uncheck the Enforce Port Classes checkbox, located at the top of the screen.

•

Remove ports from the SPAN port class.
A. Select Ports/Blades>Configuration>Classes. The Classes screen displays.
B. Click the Class Members link, located at the top of the screen. The Class Members
screen displays.
C. Uncheck SPAN class checkboxes.
D. Click the Save button.
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Setting Up and Accessing
the Switch

Chapter 3

Before running WEBX, you must first set up the switch:
For information about...
Go to this page...
Setting the IP Address .................................................................................................... 16
Setting Up User Authentication ........................................................................................ 21
Logging In ..................................................................................................................... 23
Setting Up Security ........................................................................................................ 24
Establishing Secure (SSL) Connections ........................................................................ 24
Running ASCII Command Scripts Over the LAN Ethernet Interface .................................. 27
Enabling Access to APCON Software ............................................................................. 29
What’s Next ................................................................................................................... 31
Configuring Ports and Port Access ............................................................................... 31
Logging Out ............................................................................................................... 31

3.1.

Setting the IP Address
By default, INTELLAPATCH switches ship with an IP address of 192.168.0.1, a subnet mask of
255.255.255.0, and no gateway. If it’s convenient to configure your host computer with an IP
address of the form 192.168.0.x (where x is any number from 2 to 254, inclusive), then WEBX
is immediately available. If not, to use the Ethernet connection you must change this default
IP address to one appropriate for your network, using one of these:
•

Serial Console

•

Web Browser

Note
If you plan to use more than one INTELLAPATCH switch on your network, configure them at
the same time. This avoids repeated temporary disconnections of the host computer from
your network.

Before you begin
Ensure that you have an APCON ACI-2073 board in your INTELLAPATCH chassis. This board
has adequate memory for the WEBX 2.50 firmware.
For web configuration, ensure that you have the following:
•

A web browser that supports Javascript including, but not limited to:
•

Firefox † browser, version 2.0 or later

•

Internet Explorer, version 6.x or later

Note
Ensure that your browser’s Javascript is enabled.
•

A54-3000-100 A
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•

A host computer that runs a web browser listed in the previous bullet. The host
computer’s web browser accesses the embedded WEBX.

•

An Ethernet connection between the host computer and the switch.

•

An IP address, subnet mask, and gateway (if required) appropriate for your network
assigned to the switch.

For serial configuration, ensure that you have the following:

Serial Console

•

An availabl3e serial port on the host machine.

•

A serial cable.

Changing the IP Address via Serial Console
To use the serial console to change the IP address:
1.

Connect a straight-through serial cable to the switch’s COM1 port and a host computer’s
serial port.

2.

Start a communications program, such as HyperTerminal.

3.

Establish a connection with the following parameters:
Port:
Bits per second:
Data:
Parity:
Stop bits:
Flow Control:

4.

COM1
9600
8 bits
None
1
None

Press the ENTER key 3 times. The console> prompt displays.
If the console is configured to answer with the ASCII (slashdot) command set , enter the
following to switch to CLI mode:
<ENTER>/.|CLI<ENTER>

5.

Set the IP address using one of these methods:
CLI2 (default):

configure ip

where the program prompts you to enter an IP address, subnet, and
gateway, in standard TCP/IP #.#.#.# format.
APCONCMDX:

set switch address ip_address subnet_mask
optional_gateway

where ip_address, subnet_mask, and optional_gateway are
IP addresses, in standard TCP/IP #.#.#.# format.
For example:
set switch address 10.1.1.180 255.255.255.0 10.1.1.1

The IP address command is issued and the console banner reappears. This process may
take several seconds.
Web Browser

Changing the IP Address via Web Browser
To use APCON’s WEBX software to change the IP address:

A54-3000-100 A
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Connect a host computer to the INTELLAPATCH switch:
A. Disconnect from your network the host computer you plan to use to assign the IP
address.
B. Plug the host computer’s serial cable into one of the Ethernet ports on the back of
the INTELLAPATCH switch using either a standard patch cable or a crossover cable.
The host and switch are now physically connected.

2.

Enable communication between the host computer and switch:
A. Access the host computer’s current network settings. Note them so that you can
restore them at the end of this process.
B. Temporarily change the host settings to the following:
•

IP address:
192.168. 0. x
( x is a number from 2 to 254)

•

Subnet mask:

255.255. 255. 0

•

Gateway setting:

0. 0.0. 0 or blank

The host and switch are now on the same network and can communicate.

3.

Access WEBX:
A. On the host computer, open a web browser.
B. If the host computer is configured to use a proxy server, disable the proxy setting.
C. In the browser’s address field, enter:
http://192.168.0.1

A54-3000-100 A

18

APCON, Inc.

WEBX v2.50 User Manual

Chapter 3: Setting Up and Accessing the Switch

The Switch Controller Status screen displays.
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4.

Click the Edit link, located to the right of the Primary IP Address field. The LAN Interface
screen displays:

5.

Change the IP address:
A. Type the new IP address, subnet mask and gateway (if required) you previously
received from your network administrator into the fields provided.
B. Click the Save button. The switch reroutes the browser to the new address.
If the new IP address no longer exists on the same subnet as the host computer, this
may fail. Reset the host computer to its original settings as described in step 6A.
C. Exit the browser.

6.

Reconnect the host computer to your network.
A. Reset the host computer’s IP address, subnet mask and gateway settings to their
original values.
B. Re-cable the host computer to the network.
C. Ensure that the switch is cabled to the network with a standard Ethernet patch cable.

A54-3000-100 A
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Setting Up User Authentication
When you need authentication, WEBX provides the tools required to specify the default
permission, or access level, for new user accounts. With authentication enabled, you can:
•

Restrict who can access general functionality and administrator-level configuration.

•

Use port locking.

•

Enable zoning.

•

Use APCON’s Security blades to share SPAN/Monitor ports.

Before setting up user accounts, however, you must decide which authentication method, if
any, you want to use:
Authenticate against an internal user database
stored on the INTELLAPATCH switch

Internal user
database
User Levels

Authenticate against an external
RADIUS or TACACS+server.

RADIUS or
TACACS+ server
User Levels

Logic
INTELLAPATCH switch

To set up a user database:
1.

Ensure that an IP address is set up, as described in Setting the IP Address starting on
page 16.

2.

Access WEBX:
A. On the host computer, open a web browser.
B. If the host computer is configured to use a proxy server, disable the proxy setting.
C. In the browser’s address field, enter the switch’s IP address, in standard
TCP/IP #.#.#.# format. For example:
http://192.168.0.1
The WEBX main screen displays.

A54-3000-100 A
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Select Settings>Users/Security>User Database in the Navigation pane. The User
Database screen displays:

Note: For details about options on the User Database screen, see User Database on
page 107.
4.

Set the User Database to one of these:
•

Internal: Select this option if you plan to use the internal user database.

•

RADIUS: Select this option if you plan to use a RADIUS server on your local area
network for user authentication.

•

TACACS+: Select this option if you plan to use a TACACS+ server on your local area
network for user authentication.

Set any additional options that display.
5.
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Logging In
Note
You can log in only if User Database is set to Internal, RADIUS, or TACACS+, as described
in the previous section.
After you assign the switch an IP address and add it to your network, you can log in to the
switch over the web using either an ordinary (HTTP) or a secure (HTTPS) connection. (The
first time you log in to the switch to add it to your network, a secure connection is not
available.)
Note
If you plan to use secure logins, you need an SSL certificate. For details, see Certificates on
page 125.
To log in to the switch:
1.

2.

Ensure that the following is done:
•

An IP address is set up, as described in Setting the IP Address starting on page 16.

•

The User Database is set to Internal, RADIUS, or TACACS+, as described in Setting
Up User Authentication starting on page 21.

In the browser’s address field, enter one of these:
•

For an insecure connection (default):

http://x.x.x.x

•

For a secure connection:

https://x.x.x.x

where each x is a value from 1 to 254, and the total four-part number is the IP address
assigned to the switch.
The WEBX login screen displays:

Connection type
Displays only for ordinary
(non-secure) HTTP connections

This is where the administrator can
enter a message that every user views
when logging in.

3.

Enter your User name and Password. The factory defaults are shown below:
User:
Password:
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System Message
A message supplied by the
administrator that displays
each time a user logs in

admin
secret
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Press either the Login button or the Enter key.
The switch’s main screen displays.

You can now view your switch’s settings. If you have administrator permission privileges, you
can also modify switch settings. For details about permissions, see Permissions on page 112.

3.4.

Setting Up Security
Set up WEBX to perform the switch security tasks you desire:
•

Enable secure web (HTTPS) connections, requiring users to log in using a secure SSL
connection. You can also generate the SSL certificate required to enable secure SSL
logins.

•

Enable secure command line (APCONCMDX) connections, allowing users to log in using an
SSH connection. You can also generate the SSH key required to enable SSH.

•

Enable one or more users to issue ASCII commands or run ASCII-command scripts over
the network.

•

Change the default serial port console mode to the ASCII scripting mode.

•

Enable access to APCON software products such as APCONCMDX, CONTROLX,
and MONITOR.

You set up these tasks on the Security/Services screen. For details about other options on
this screen, see Service Properties on page 117.

3.4.1.

Establishing Secure (SSL) Connections
When you require all management functions—including user authentication—to run over a
secure connection, you can enable SSL as described in the following steps.
Note
SSL is slower than non-secure HTTP.
To require all users to log in using a secure SSL connection:
1.

Ensure that an IP address is set up, as described in Setting the IP Address starting on
page 16. APCON recommends that you also set the User Database to Internal, RADIUS or
TACACS+, as described in Setting Up User Authentication on page 21.

2.

Log in as described in Logging In on page 23.
Note
If authentication is enabled, you must log in with Administrator permission privileges.
For details about permissions, see Permissions on page 112.
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3.

Select Settings>Services>Certificates. The Certificates screen displays:

4.

Click the Generate SSL certificate button.
WEBX generates the SSL certificate. This may take up to three minutes to complete; do
not cancel or change screens during generation. When the certificate is generated, this
message displays:
Keys generated...
Service restarting...SUCCESS

5.

Select Settings>Services>Certificates to refresh and re-display the screen.

6.

Check the Force secure (HTTPS) logins checkbox, then click the Update button.
You are prompted to verify your actions. WEBX enables secure logins, then displays the
View>Controller Status screen.

When users log on, it will be via a secure connection.
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Establishing SSH Connections
When you require command line communication to run over a secure connection, you can
enable SSH as described in the following steps.
To require all users to log in using an SSH connection:
1.

Ensure that an IP address is set up, as described in Setting the IP Address starting on
page 16.

2.

Log in as described in Logging In on page 23.
Note
If authentication is enabled, you must log in with Administrator permission privileges.
For details about permissions, see Permissions on page 112.

3.

Select Settings>Services>Certificates. The Certificates screen displays:

4.

Click the Generate SSH key button.
WEBX generates the SSH key. This may take up to three minutes to complete; do not
cancel or change screens during generation. When the key is generated, this message
displays:
Keys generated...
Service restarting...SUCCESS
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Select Settings>Services>Certificates to refresh and re-display the screen.

6.

Check the Enable SSH checkbox, then click the Update button.
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You are prompted to accept the certificate. WEBX enables SSH, then displays the
Settings>Services>Certificates screen.
7.

Uncheck the Enable Telnet checkbox, then click the Update button.
Note: This prevents both secure SSH and non-secure telnet from being simultaneously
available.

When users use telnet, it will be via a secure connection.

3.4.3.

Running ASCII Command Scripts Over the LAN
Ethernet Interface
To Enable one or more users to issue ASCII commands or run ASCII-command scripts over
the network:
1.

Ensure that an IP address is set up, as described in Setting the IP Address starting on
page 16.

2.

Log in as described in Logging In on page 23.
Note
If authentication is enabled, you must log in with Administrator permission privileges.
For details about permissions, see Permissions on page 112.
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3.

Select Settings>Services>Service Properties. The Service Properties screen displays:

4.

Check the Enable ASCII (Slash) commands over network checkbox. The Enable
simultaneous ASCII commands field displays.

5.

(Optional) If you want more than one user to send ASCII commands over the network at
the same time, check the Enable simultaneous ASCII commands checkbox.

6.

Click the Update button.
You can now run ASCII commands over the network. If you selected both checkboxes,
multiple users or scripts can concurrently run ASCII commands over the network.
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Enabling Access to APCON Software
WEBX is set, by default, to enable network use of these APCON software products:
TITAN
APCONCMDX
CONTROLX
MONITOR

Note
These products must be installed on a computer connected to your network.
For a description of these products, see Related Products on page 3.

If you plan to use any of these APCON products, ensure that WEBX enables their use.
To enable network use of APCON software products:
1.

2.

Ensure that the following has occurred:
•

An IP address is set up, as described in Setting the IP Address starting on page 16.

•

The User Database is set to Internal, RADIUS, or TACACS+, as described in Setting
Up User Authentication starting on page 21.

Log in as described in Logging In on page 23.
Note
If authentication is enabled, you must log in with Administrator permission privileges.
For details about permissions, see Permissions on page 112.
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3.

Select Settings>Services>Service Properties. The Service Properties screen displays:

4.

Check the Enable RPC checkbox.

5.

Click the Update button.

You can now access installed APCON software products.
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3.5.

What’s Next

3.5.1.

Configuring Ports and Port Access
Although you can complete these tasks at any time, you may now want to set up
the following:

3.5.2.

•

Data Rate Selection. For information about data rates, see Rates on page 52.

•

Port names. For information about naming ports, see Names on page 63.

•

Zones. For information about zoning, see Zoning on page 70.

•

Classes. For information about classes, see Classes on page 65.

Logging Out
To log out of the switch, click the Logout prompt, located on the
upper right side of the screen:

Logout prompt
includes the current
user’s login name
Logout admin (Administrator)

Note
The switch automatically logs out users who have left the switch idle for over six hours.
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This chapter details the screens available from the Connections menu:
For information about...
Go to this page...
Realtime ....................................................................................................................... 33
Patch Mode ............................................................................................................... 41
By Name ....................................................................................................................... 42
By Name: Review ....................................................................................................... 43
By Preset (Presets) ........................................................................................................ 45
With MONITOR (MONITOR) ................................................................................................ 46
View Patches ................................................................................................................. 47
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Realtime
Configuring your switch’s patches in Batch mode means the patch settings immediately take
effect. Select this option when you have few changes to make or when you need to
immediately implement your changes.
Note
After setting up classes and assigning ports to those classes, you can quickly view and
modify settings for SPAN and Analyzer ports by accessing the Monitor screen. For
information about setting up classes, see Classes on page 65. For information about
modifying settings, see Chapter 5, MONITOR, starting on page 48.
To view and configure your switch’s current patches, select:
Connections>Patching>Realtime
This screen displays on the Canvas (this figure is truncated to more easily identify parts):
Figure 8. Patch Ports: Realtime and Batch screens
Patch mode

Blade power
LED

Port number

Port status LED
Port name

Locked port (striped)
Zoned port (black)
Locked port (red)
Blade letter

Patched port
Patch mode

The screen includes these options:
Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Patch mode

TRASH
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Description
Clicking these radio buttons determines the direction of data flow:
• Duplex (normal): All patching occurs in duplex, or bidirectional,
mode.
• Simplex (advanced): All patching occurs in simplex, or single
direction, mode.
This option also displays at the bottom of the screen.
Disconnects the selected port.
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Field
Cancel Drag
Lock/Unlock
Search...

Refresh button

Save button

Locked port
(red and striped)

Zoned port
(black)
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Description
Discards, without saving changes, an in-process patch.
Locks or unlocks the “picked up” port.
Displays a Search screen where you type the port name (a string)
you want to locate:
Backspace key
Clears characters. Use to correct entries.
Clear
Clears an entry. Use to make new entries.
Up/down arrows Highlights the previous or next match, when
more than one match displays.
Enter key
Selects the highlighted item.
(Displays only on the Batch screen) Clicking this button retrieves
current information from the switch and displays it on the screen.
When data changes (or might have changed), click the Refresh
button to update the view.
(Displays only on the Batch screen) Clicking this button saves
and implements your changes.
This button displays only on the Connections>Patch ing>Batch
screen. It also displays at the bottom of the screen.
Ports highlighted in red are not available for your use. They are
reserved for the exclusive use of a specified user. Ports
highlighted in red stripes are locked by you. Although they are
reserved, you can unlock them.
For information about locked (reserved) ports, see Locks on
page 54.
Note: If locked ports are not red, clear your internet cache:
1. Close the web browser.
2. Select Start>Settings>Control Panel>Internet Options.
3. In Temporary Internet Files, click the Delete Files button, then
click the OK button.
4. Restart your web browser and access the switch.
Ports highlighted in black are not available for your use. These
ports belong to a zone that you do not have permission to access.
For information about zones, see Zoning on page 70
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Patched port

Patch mode
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Description
Identifies the port and serves as a link location when patching
port to one another. To patch a port:
1. Ensure that Data flow is set to the value you want: Duplex or
Simplex.
Note: For details about how Patch Mode affects your patching,
see Patch Mode, following this table.
2. Place the cursor over a port label or patched port textbox, then
click. The following actions occur:
• A status message at the bottom of the screen identifies the
port you selected.
• The action popup— which includes Trash, Lock Port, and
Cancel links—displays at the top of the screen.
3. Do one of these:
• Click the label of a port—the port you want the selected port
to patch to. Labels of the selected port(s) display in the
Patched Port field of one or both ports, depending on the
Data Flow you selected.
• Click the action link that produces the action you desire:
• Trash: Disconnects one or both ports, depending on the
Data Flow you selected.
• Cancel drag: Terminates the current patch operation.
• Lock Port: Locks the port for the number of minutes you
specify. You can optionally add a message regarding the
lock. For details about locked (reserved) ports, see
Locks on page 54.
Note: To verify a port’s status and connections, hover the cursor
over the port. Port status displays in a popup.
The LED color indicates port status:
• Green: A signal is present. The letters indicate the rate: 10,
100, or GIGE (Gigabit Ethernet).
• Gray: No signal is present.
Identifies the blade and port number this port is linked to. Also
serves as a link location when patching port to one another. To
patch a port, see Port number (at top of page).
The background color indicates port status:
• White: An SFP transceiver is inserted in the port, or the port is
copper—which doesn’t use an SFP transceiver.
• Green: An SFP transceiver is inserted in the port and the port
is receiving signal, or the port is copper and it is receiving
signal.
• Gray: No transceiver is installed, and the port is not copper.
Identifies the patch mode:
Simplex
Duplex
For details, see Patch Mode on page 36.
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Description
Displays the blade position within the chassis.
Blade labels use letters and start at the bottom. Port labels use
numbers prefaced by blade letter, and start at the left. For more
information, see Switch Labeling on page 9.
The LED color indicates blade status:
• Green: This blade’s power is on.
• Gray: This blade’s power is off.
The LED is also a link which, when clicked, displays the Blade
Power screen. For details about this screen, see Power on
page 59.

Patch Mode
The Patch mode you select results in the following:
•

Duplex (normal): Connected ports each transmit and receive.
When you select port A01, then select port A02, the ports
connect and each port transmits or receives simultaneously.

Duplex
Connecting

The label of the first selected port displays in the Patched Port
field of the second selected port, and the label of the second
selected port displays in the Patched Port field of the first
selected port
This bi-directional connection is indicated at the bottom of the
screen with the “
” symbol.

Disconnecting

When you select either port, then click Trash, both ports
disconnect.
If you change to Simplex mode, then select a port and click
Trash, the port you selected disconnects.
•

Simplex (advanced): Connected ports either transmit or receive.
When you select port A01, then select port A02, port A01 sends
data to port A02. The label of the first selected port displays in
the Patched Port field of the second selected port. This singledirection connection is indicated at the bottom of the screen
with the “ ” symbol.

Simplex
Connecting

When you select port A01, then click Trash, the connection
between A01 and A02 remains unchanged. When you select
port A02, then click TRASH , the ports disconnect.
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Batch
Configuring your switch’s patches in Batch mode means the patch settings take effect only
after you click the Save button. Select this option when you have multiple patches to make in
a single transaction, or for complex changes.
Note
After setting up classes and assigning ports to those classes, you can quickly view and
modify settings for SPAN and Analyzer ports by accessing the Monitor screen. For
information about setting up classes, see Classes on page 65. For information about
modifying settings, see Chapter 5, MONITOR, starting on page 48.
To view and configure your switch’s current patches, select:
Connections>Patching>Batch
This screen displays on the Canvas (this figure is truncated to more easily identify parts):
Figure 9. Patch Ports: Realtime and Batch screens
Patch mode

Blade letter
Port number
Locked port (striped)
Zoned port (black)
Locked port (red)

Port status LED Blade power LED
Port settings
Patched port

The screen includes these options:
Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Patch mode

TRASH

Cancel Drag
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Description
Clicking these radio buttons determines the direction of data flow:
• Duplex (normal): All patching occurs in duplex, or bidirectional,
mode.
• Simplex (advanced): All patching occurs in simplex, or single
direction, mode.
This option also displays at the bottom of the screen.
Disconnects the selected port.
Discards, without saving changes, an in-process patch.
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Search...

Refresh button

Save button

Locked port
(red and striped)

Zoned port
(black)
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Description
Displays a Search screen where you type the port name (a string)
you want to locate:
Backspace key
Clears characters. Use to correct entries.
Clear
Clears an entry. Use to make new entries.
Up/down arrows Highlights the previous or next match, when
more than one match displays.
Enter key
Selects the highlighted item.
(Displays only on the Batch screen) Clicking this button retrieves
current information from the switch and displays it on the screen.
When data changes (or might have changed), click the Refresh
button to update the view.
(Displays only on the Batch screen) Clicking this button saves
and implements your changes.
This button displays only on the Connections>Patch ing>Batch
screen. It also displays at the bottom of the screen.
Ports highlighted in red are not available for your use. They are
reserved for the exclusive use of a specified user. Ports
highlighted in red stripes are locked by you. Although they are
reserved, you can unlock them.
For information about locked (reserved) ports, see Locks on
page 54.
Note: If locked ports are not red, clear your internet cache:
1. Close the web browser.
2. Select Start>Settings>Control Panel>Internet Options.
3. In Temporary Internet Files, click the Delete Files button, then
click the OK button.
4. Restart your web browser and access the switch.
Ports highlighted in black are not available for your use. These
ports belong to a zone that you do not have permission to access.
For information about zones, see Zoning on page 70
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Field
Search...

Refresh button

Save button

Locked port
(red and striped)

Zoned port
(black)
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Description
Displays a Search screen where you type the port name (a string)
you want to locate:
Backspace key
Clears characters. Use to correct entries.
Clear
Clears an entry. Use to make new entries.
Up/down arrows Highlights the previous or next match, when
more than one match displays.
Enter key
Selects the highlighted item.
(Displays only on the Batch screen) Clicking this button retrieves
current information from the switch and displays it on the screen.
When data changes (or might have changed), click the Refresh
button to update the view.
(Displays only on the Batch screen) Clicking this button saves
and implements your changes.
This button displays only on the Connections>Patch ing>Batch
screen. It also displays at the bottom of the screen.
Ports highlighted in red are not available for your use. They are
reserved for the exclusive use of a specified user. Ports
highlighted in red stripes are locked by you. Although they are
reserved, you can unlock them.
For information about locked (reserved) ports, see Locks on
page 54.
Note: If locked ports are not red, clear your internet cache:
1. Close the web browser.
2. Select Start>Settings>Control Panel>Internet Options.
3. In Temporary Internet Files, click the Delete Files button, then
click the OK button.
4. Restart your web browser and access the switch.
Ports highlighted in black are not available for your use. These
ports belong to a zone that you do not have permission to access.
For information about zones, see Zoning on page 70
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Field
Port number

Port Status LED

Port settings
[R P C]

Chapter 4: Connections

Description
Identifies the port and serves as a link location when patching
port to one another. To patch a port:
1. Ensure that Data flow is set to the value you want: Duplex or
Simplex.
Note: For details about how Patch Mode affects your patching,
see Patch Mode, following this table.
2. Place the cursor over a port label or patched port textbox, then
click. The following actions occur:
• A status message at the bottom of the screen identifies the
port you selected.
• Action links—Trash and Cancel drag—display at the top and
bottom of the screen.
3. Do one of these:
• Click the label of a port—the port you want the selected port
to patch to. Labels of the selected port(s) display in the
Patched Port field of one or both ports, depending on the
Data Flow you selected.
• Click the action link that produces the action you desire:
• Trash: Disconnects one or both ports, depending on the
Data Flow you selected.
• Cancel drag: Terminates the current patch operation.
The LED color indicates port status:
• Green: A signal is present. The letters indicate the rate: 10,
100, or GIGE (Gigabit Ethernet).
• Gray: No signal is present.
Each letter within the braces is a separate option. Selecting an
option produces these results:
R
(Rate Select) Displays the port’s Set Rate Selection
screen. For information about the options on this
screen, see Rates on page 52.
P

(Port Properties) Displays the port’s Port Properties
screen. For information about the options on this
screen, see Port Properties on page 50.

C

Patched port

A54-3000-100 A

(Connections) Highlights all ports connected to this
port. Select this option to quickly identify ports
patched to the source.
Identifies the blade and port number this port is linked to. Also
serves as a link location when patching port to one another. To
patch a port, see Port number (at top of page).
The background color indicates port status:
• White: An SFP transceiver is inserted in the port, or the port is
copper—which doesn’t use an SFP transceiver.
• Green: An SFP transceiver is inserted in the port and the port
is receiving signal, or the port is copper and it is receiving
signal.
• Gray: No transceiver is installed, and the port is not copper.
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Field
Blade letter

Blade power LED

4.2.1.

Chapter 4: Connections

Description
Displays the blade position within the chassis.
Blade labels use letters and start at the bottom. Port labels use
numbers prefaced by blade letter, and start at the left. For more
information, see Switch Labeling on page 9.
The LED color indicates blade status:
• Green: This blade’s power is on.
• Gray: This blade’s power is off.
The LED is also a link which, when clicked, displays the Blade
Power screen. For details about this screen, see Power on
page 59.

Patch Mode
The Patch mode you select results in the following:
•

Duplex (normal): Connected ports each transmit and receive.
When you select port A01, then select port A02, the ports
connect and each port transmits or receives simultaneously.

Duplex
Connecting

The label of the first selected port displays in the Patched Port
field of the second selected port, and the label of the second
selected port displays in the Patched Port field of the first
selected port
This bi-directional connection is indicated at the bottom of the
screen with the “< >” symbol.

Disconnecting

When you select either port, then click Trash, both ports
disconnect.
If you change to Simplex mode, then select a port and click
Trash, the port you selected disconnects.
•

Simplex (advanced): Connected ports either transmit or receive.
When you select port A01, then select port A02, port A01 sends
data to port A02. The label of the first selected port displays in
the Patched Port field of the second selected port. This singledirection connection is indicated at the bottom of the screen
with the “>> ” symbol.

Simplex
Connecting

When you select port A01, then click Trash, the connection
between A01 and A02 remains unchanged. When you select
port A02, then click TRASH , the ports disconnect.

A54-3000-100 A
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Chapter 4: Connections

By Name
To quickly configure patch settings, select:
Connections>Patching>By Name
This screen displays on the Canvas:
Figure 10. By Name screen

The screen includes these options:
Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Patching By
Name/Number

A54-3000-100 A

Description
Use the top section of the screen when you know the name
and/or number of the ports you want to connect, or to enter many
target ports in a single entry.
• Source Port: Enter the source port name or number—the port
you want to patch from—in the text box on the left.
• Target Ports: Enter the target port or ports—the port(s) you
want the selected port to patch to—in the text box on the right.
You can enter either the name or number.
Entering A00 turns the port off; A99 leaves the port unchanged.
By default, all patching occurs in duplex, or bidirectional,
mode. To change the mode, click the Review button.
• Review button: Click this button to display the Quick Patch
Review dialog box where you can customize your entry. For
information about this dialog box, see By Name: Review on
page 43.
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Field
Duplex/Simplex
Patching
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Description
Use the middle section of the screen to display a list of ports from
which you can select:
• Source Port: Select the source port—the port you want to patch
from—from the drop-down list on the left.
• Target Port: Select the target port—the port(s) you want the
selected port to patch to—in the drop-down list on the right.
• Direction: Indicates the direction of data:
>> (Simplex): Data flows from the Source to the Target.
<> (Duplex): Data flows both directions.
• Connect button: Click this button to save and implement your
settings.

Disconnecting

To disconnect a port:

• Port: Select the port you want to disconnect from the dropdown list.
• Disconnect button: Click this button to disconnect the port.
Note: If the port you disconnect is bi-directionally patched to
another port, the other port also disconnects.

4.3.1.

By Name: Review
Figure 11. By Name: Review dialog box

The dialog box includes these options:
Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Patch this port
to

Description
Displays the source port—the port you want to patch from—in the
left column.
Indicates the direction of data:
>> (Simplex): Data flows in only one direction.
<> (Duplex): Data flows both directions.
Note: By default, all patching occurs in duplex, or bidirectional,
mode. You can change the mode on this screen.

A54-3000-100 A
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Field
this port
Save button
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Description
Displays the target port or ports—the port(s) you want the
selected port to patch to—in the right column.
Click this button to save and implement your settings.
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By Preset (Presets)
Saves, changes, or clears configuration settings, referred to as “presets.” You can save up to
ninety nine different switch configurations as a preset. Once you reach ninety nine saved
configurations, you must clear an existing preset configuration to make room for a new one.
To create, change, and delete switch settings, select:
Connections>Patching>Presets
These screens display simultaneously on the Canvas:
Figure 12. By Preset (Presets) screens

The screen includes these options:
Note
To make changes on this screen, your account must have a minimum of Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Preset 1–99

Load Preset button

Undo Preset button
To create or edit
presets, please see:
[Edit Presets]

A54-3000-100 A

Description
A configuration assigned to this preset number and name.
A configuration includes only patch connections.
For information about assigning a configuration to a Preset, see
Edit Presets on page 75.
Sets the switch to the configuration to the preset name or number
selected in the list at left.
CAUTION: This action overwrites current patch settings.
Displays the Edit Presets screen where you can set switches to a
saved configuration. For more information about this screen, see
page 75.
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Chapter 4: Connections

With MONITOR (MONITOR)
To access APCON’s MONITOR software which non-intrusively connects to and controls any
INTELLAPATCH switch using the PC’s serial port or TCP/IP LAN connection and shares
equipment, select:
Connections>Patching>MONITOR
The MONITOR screen displays. For more information about MONITOR, see chapter Chapter 5,
MONITOR, starting on page 48.
Note
To use the MONITOR feature, you must fbtain a license key from APCON. For information
about license keys, see License Key on page 98. To find out how to contact APCON, see
Contacting APCON on page 4.
Note
You can also acess this tool by selecting:
Connections>MONITOR

A54-3000-100 A

46

APCON, Inc.

WEBX v2.50 User Manual

4.6.

Chapter 4: Connections

View Patches
To view your switch’s current patch connections, select:
Connections>Patching>View Patches
This screen displays on the Canvas:
Figure 13. View Patches screen

Refresh timer

The screen includes these options:
Note
To view this screen, your account needs only Guest permission privileges. For details about
permissions, see Permissions on page 112.
Field
Name
Port

Direction

Refresh timer
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Description
The port name you specify. For information about naming ports,
see Names on page 63.
The port number. Blade labels use letters and start at the bottom.
Port labels use numbers prefaced by blade letter, and start at the
left. For details, see Switch Labeling on page 9.
Indicates the direction of data:
>> (Simplex): Data flows in only one direction.
<> (Duplex): Data flows both directions.
Displays the number of seconds remaining before the data
refreshes. A refresh occurs every thirty seconds.
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Chapter 5

MONITOR

Chapter 5

MONITOR software connects to and controls any APCON INTELLAPATCH Physical Layer Switch
using the PC’s serial port or TCP/IP LAN connection. The software is specifically tailored for
non-intrusive network monitoring and for sharing equipment such as traffic analyzers,
network probes and Intrusion Detection System (IDS) equipment.
A powerful addition to your network administration toolset, you use APCON MONITOR
software to:
•

Electronically move and share monitoring equipment to increase utilization of existing
equipment.

•

Increase network visibility, getting a quick snapshot of network connections to monitoring
devices.

•

Gather information at-a-glance about ports, connections, data rates and more.

•

Employ digital diagnostics and INTELLAPATCH switch monitoring.

•

Control user permissions for modifying system status and software options.

Note
MONITOR software is not intended for in-line monitoring/electronic tapping, wherein data is
passed through the switch, with traffic in both directions mirrored non-intrusively by the
analyzer device. To implement this functionality, consider the WEBX Realtime or Batch
interfaces.
Accessing MONITOR software through WEBX requires a license key from APCON. To find out
how to contact APCON, see Contacting APCON on page 4. After obtaining the key, you must
activate the MONITOR feature as described in License Key on page 98.
To find out more about operating MONITOR software, see the MONITOR User Manual.

A54-3000-100 A
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Chapter 6

Ports/Blades

Chapter 6

This chapter details the screens available from the Ports/Blades menu:
For information about...
Go to this page...
Ports ............................................................................................................................ 50
Port Properties ........................................................................................................... 50
Rates ........................................................................................................................ 52
Locks ........................................................................................................................ 54
Blades .......................................................................................................................... 57
Properties .................................................................................................................. 57
Power ....................................................................................................................... 59
SFP/XFP ....................................................................................................................... 60
Properties .................................................................................................................. 60
Alarms ...................................................................................................................... 61
Configuration ................................................................................................................. 63
Names ...................................................................................................................... 63
Classes ..................................................................................................................... 65
Class Members .......................................................................................................... 67
Port Locking .............................................................................................................. 69
Zoning ...................................................................................................................... 70
Receive Monitoring ..................................................................................................... 74
Edit Presets ............................................................................................................... 75
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6.1.

Ports

6.1.1.

Port Properties

Chapter 6: Ports/Blades

Many transceiver modules have manufacturer-provided identification capabilities, allowing you to
determine part numbers, serial numbers, supported transmission media, protocol compliance,
maximum data rate, digital diagnostics, or other vendor-specific parameters.
To view transceiver details, select:
Ports/Blades>Ports>Properties
This screen displays on the Canvas:
Figure 14. Port Properties screen

Screen appearance
before selecting a port

Details that display
after selecting a port
Note: Digital Diagnostics
display only for SFPs that
support this feature.

The screen includes these options:
Note
To make changes on this screen, your account needs only Guest permission privileges. For
details about permissions, see Permissions on page 112.

A54-3000-100 A
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Field
Port numbers

Description
Identifies ports. The background color indicates port status:
• White: An SFP transceiver is inserted in the port, but is not
receiving signal.
• Green: An SFP transceiver is inserted in the port and the port
is receiving signal.
• Gray: No transceiver is installed.
To select the port whose transceiver information you want to view,
place the cursor over port number and click. The screen enlarges
to display vendor information. You can display only one port’s
vendor information at a time.
Blades that do not support SFP transceivers (for example, copper
blades) display this message:
unsupported on Blade n
Vendor information
Displays the vendor name, part number and revision, serial
number, date, maximum data rate, and any other information the
vendor makes available.
Transmitter Technology Displays the transmitter capabilities of this SFP transceiver:
Unchecked: The SFP transceiver does not support the
specified item.

Protocol Compliance

Checked: The SFP transceiver supports the specified item.
To determine whether the blade supports the item, see
Rates (page 52) and the blade’s data sheet.
Displays the protocols this device complies with:
Unchecked: The SFP transceiver does not support the
specified item.

Digital Diagnostics

Transmission Media
Supported

Checked: The SFP transceiver supports the specified item.
To determine whether the blade supports the item, see
Rates (page 52) and the blade’s data sheet.
Displays real-time digital diagnostics for SFPs that support this
feature.
Real-time parameters include transceiver temperature, laser bias
current, transmitted and received optical power, transceiver
supply voltage, and alarm status.
Displays the supported transmission media supported by the
device:
Unchecked: The SFP transceiver does not support the
specified item.
Checked: The SFP transceiver supports the specified item.
To determine whether the blade supports the item, see
Rates (page 52) and the blade’s data sheet.

A54-3000-100 A
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Rates
Depending on the capabilities of a given port, you can change the data rate and other transmission
characteristics.
To set your switch’s data transmission rate, select:
Ports/Blades>Ports>Rates
This screen displays on the Canvas:
Figure 15. Rates screen

Port name

Current rate

Rate select

The screen includes these options:
Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Blades
(Tabs A, B, C ...)
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Description
Clicking a tab displays the rate settings for the specified blade.
Tab letters match the blade numbers on your I NETELLAP ATCH
chassis. Blade labels use letters and start at the bottom. Port
labels use numbers prefaced by blade letter, and start at the left.
For details, see Switch Labeling on page 9.

52

APCON, Inc.

WEBX v2.50 User Manual

Field
Port name

Current rate

Rate select

Set all
Refresh button
Save button

A54-3000-100 A
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Description
Identifies the port assignment. The port name consists of:
PortNumber:PortName
Where PortNumber is the number assigned to the port and
PortName is the name you specify. If you do not specify a port
name, Unnamed displays.
For information about naming ports, Names on page 63.
Displays the rate at which the port currently transmits data and
the duplex setting, either full or half. Blades that do not have a
rate select option display N/A.
The rate at which the port transmits data. Each blade model
supports different options; some values include:
• Auto: The switch negotiates the fastest possible rate to
transmit data, and accommodates changing devices with
maximum flexibility.
• Full/half: Allows the port to transmit and receive in full duplex
mode when connected to a duplex device, but negotiate down
to half duplex automatically when necessary.
• N/A: Not applicable
Selecting a value sets all the ports on this blade to the specified
rate when you click the Save button.
Clicking this button retrieves current information from the switch
and displays it on the tab.
Clicking this button saves and implements your changes.
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Locks
Reserves the specified port(s) for your exclusive use.
To access port locking options, select:
Ports/Blades>Ports>Locks
This screen displays on the Canvas:
Figure 16. Locks screen
Port locking status

Displays when
Port Locking is
disabled.

Displays when
Port Locking is
enabled.

Lock details

See Locks on
page 54

The screen includes these options:
Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Port locking status

Change

Tabs

A54-3000-100 A

Description
Located at the top of the screen, this message indicates:
• Port locking status, either enabled or disabled.
• Maximum lock duration, either a fixed or unlimited number of
minutes.
• Disposition of connections when lock duration expires.
Clicking this link displays the Port Locking screen where you can
specify the port lock settings to allow. For details about this
screen, see page 69.
Clicking a tab displays the the following
• View By Port tab, shown in the above figure, that you use to
lock and unlock ports. Ports display by blade.
• View By User tab, shown on page 55, that you use to view ports
locks set by each user, and to unlock ports.
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Field
Ports

Lock details

Toggle
Port lock settings

Save button

6.1.3.1.

Chapter 6: Ports/Blades

Description
Identifies the port and serves as the link location when locking
ports. To lock a port:
1. Select the port(s) you want to lock using one of these methods:
• Place the cursor over the port’s checkbox and click.
• Click the Toggle link, located on the right side of the screen,
for the blade whose ports you want to lock.
2. Specify the port lock settings, located at bottom of the screen.
3. Click the Save Changes button.
Locked ports display as red, while unlocked ports remain green.
Hovering your cursor over a port displays the following lock
information for that port:
• Port number: Port name: Identifies the port assignment.
PortNumber is the number assigned to the port and PortName is
the name you specify. If you do not specify a port name,
Unnamed displays.
For information about naming ports, Names on page 63.
• Locked by: The login name of the user that set the lock.
• Remaining time: The number of minutes the lock remains in
effect.
• Message (optional): A message from the user that set the lock.
Checks or unchecks all ports on the selected blade.
Specifies the settings for this lock operation:
• Lock selected ports for n minutes with the status message abc:
Specifies the duration of the lock and the message that displays
when users try to access a port while locked.
Note: To change the number of minutes, you must cancel the
lock, then lock the port again with a different duration.
• Unlock selected ports: Releases the lock
Clicking this button saves and implements your changes.

Locks: View By User tab
Figure 17. Locks: View By User tab
Port locking
status

User name
Locked ports

The screen includes these options:

A54-3000-100 A
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Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Port locking status

Tabs

User name
Locked ports

Unlock Selected Ports
button
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Description
Located at the top of the screen, this message indicates:
• Port locking status, either enabled or disabled.
• Maximum lock duration, either a fixed or unlimited number of
minutes.
Clicking a tab displays the the following
• View By User tab, shown in the above figure, that you use to
view ports locks set by each user, and to unlock ports.
• View By Port tab, shown on page 54, that you use to lock and
unlock ports. Ports display by blade.
Displays the user’s login name.
Displays the ports locked by each user. You can also unlock a
ports from this screen:
Note: Users with Administrator permission privileges can unlock
any port. Users with Advanced Operator Other permission
privileges can unlock only the ports they locked.
1. Select the port or ports you want to unlock using one of these
methods by placing the cursor over the port’s checkbox and
clicking.
2. Click the Unlock Selected Ports button. The View By Port tab
displays.
Unlocks the specified ports and displays the View By Port tab.
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Blades

6.2.1.

Properties

Chapter 6: Ports/Blades

To view your switch’s current patches, settings, and port properties, select:
Ports/Blades>Blades>Properties
This screen displays on the Canvas:
Figure 18. Properties screen

The screen includes these options:
Note
To view this screen, your accountneeds only Guest permission privileges. For details about
permissions, see Permissions on page 112.
Field
Switch

A54-3000-100 A

Description
The screen’s top section displays information about the switch:
• Switch name: The name and IP address you specified for the
switch.
To change the switch name, see Properties on page 57. To
change the IP address, see LAN Interface on page 129.
• Power: Indicates whether power is supplied to the switch.
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Field
Switch

Port#
Name
Rate/Protocol

SFP

Signal

Simplex/Duplex

Chapter 6: Ports/Blades

Description
• Temperature: Indicates temperature and status:
• Green: Internal temperature is within specified limits.
• Flashing red: Internal temperature exceeds the specified
maximum temperature threshold. If this occurs, the switch
also emits an audible alarm, provided the audible alarm is
enabled. For information about audible alarms, see
Properties on page 133.
The default temperature threshold is 50° C. To change the
default, see Properties on page 133.
• Power Supply n Alarm: Indicates operational status of the
specified power supply.
• Green: The power supply is functioning normally.
• Flashing red: The power supply failed. If this occurs, the
switch also emits an audible alarm, provided the audible
alarm is enabled. For information about audible alarms, see
Properties on page 133.
• SFP Warnings and SFP alarms: Indicates whether any SFP
warnings or alarms exist
• Gray: Monitoring is disabled.
• Green: No alarms exist; SFPs are functioning normally.
• Flashing red: At least one SFP warning or alarm exists.
Clicking the links to the left of the LED displays the Alarms
screen where you can view warning and alarm details. For
more information about this screen, see Alarms on page 61.
The port number.
The port name.
Specifies the data rate and protocol the port is currently
negotiated at or hard set to. Fiber optic blades that don’t support
auto-negotiation display only signal or no signal.
Indicates transceiver status:
• Y (Yes): An SFP transceiver is inserted in the port, or the port is
copper.
• N (No): No SFP transceiver exists.
Indicates signal status:
(Green) The port currently has signal.
(Gray)
The port does not have a signal.
Displays the direction of data flow:
D (Duplex) The port is configred in duplex, or bidirectional, mode.
S (Simplex) The port is configured in simplex, or single direction,
mode.
n/c

A54-3000-100 A

No connection.
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Power
Before inserting or removing a blade, power to its slot must be turned off.
To turn a blade slot’s power off or on, select:
Ports/Blades>Blades>Power
This screen displays on the Canvas:
Figure 19. Power screen

Power

Note
To make changes on this screen, your account must have a minimum of Administrator
permission privileges. For details about permissions, see Permissions on page 112.
The screen includes these options:
Field
Blade

Power

ALL
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Description
Identifies the blade, and therefore slot, whose power status you
want to change.
Blade labels use letters and start at the bottom. For details, see
Switch Labeling on page 9.
Determines the blade slot power status:
• ON: Turns blade power on. When you select this option, the
background changes to green.
• OFF: Turns blade power off. When you select this option, the
background changes to red.
Sets the blade slot power status for all blades in the chassis:
• ON: Turns power on for all blades. When you select this option,
the background changes to green.
• OFF: Turns power off for all blades. When you select this
option, the background changes to red.
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6.3.

SFP/XFP

6.3.1.

Properties

Chapter 6: Ports/Blades

Displays SFP transceiver information in a format you can quickly view and copy.
To display transceiver properties, select:
Ports/Blades>SFP/XFP>Properties
This screen displays on the Canvas:
Figure 20. Properties screen

Port
Company
SFP part number
Revision
Serial number
Manufacture date
RX signal strength
Internal temperature
Power supply voltage

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see User Levels on page 95.
Field
Load
Port
Company
SFP part #
Revision
Serial number
Manufacture date
RX signal strength
Internal temperature
Power supply voltage

A54-3000-100 A

Description
Clicking this link loads and displays SFP information for the blade
or blades you select.
Identifies the port.
Displays APCON as the INTELLAPATCH switch manufacturer.
The SFP’s part number.
The switch’s revision number.
The switch’s serial number.
The switch’s manufacture date.
Displays the SFP’s Receive signal strength.
Indicates SFP temperature.
Indicates SFP voltage.
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Alarms
Indicates warning and error conditions for the SFP transceivers.
To monitor transceiver status, select:
Ports/Blades>SFP/XFP>Alarms
This screen displays on the Canvas:
Figure 21. Alarms screen

Error icons

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.

A54-3000-100 A
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Error icons
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Description
When red, each icon alerts you to an error in any of these areas:
Power

Receive1

Transmit
Temperature
For details about an error, hover over or click the red icon. The
Port Properties screen, with error detail, displays. For information
about this screen, see Port Properties on page 50.
1

You can specify which ports to monitor and which to ignore. For
details, see Receive rate ignored by RX Monitor settings (below).

Ignored ports display an inactive (gray) icon with an “X” ( )
Determines whether and how data on the screen refreshes:
• Disable refresh: Data does not refresh.
• Enable refresh: Refreshes data at the interval specified in
“refresh every n seconds.” The default is 1800 seconds (30
minutes).
While an alarm condition exists, data refreshes every
10 seconds (overriding the specified Refresh rate) until the
alarm/warning is resolved.
Save button
Clicking this button saves and implements your changes.
Receive rate ignored by Clicking the RX Monitor settings link displays the Monitoring
screen where you specify which port signals to monitor and which
RX Monitor settings
to ignore. For details about this screen, see Receive Monitoring on
page 74.
Refresh rate

A54-3000-100 A
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Although port numbers are automatically designated, you can assign names to your ports,
names that indicate devices they connect to or to provide other meaningful aids to memory.
INTELLAPATCH blade labels use letters and start at the bottom. Port labels use numbers
prefaced by blade letter, and start at the left. For details, see Switch Labeling on page 9.
To name ports, select:
Ports/Blades>Configuration>Names
This screen displays on the Canvas:
Figure 22. Names screen

The screen includes these options:
Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Blade:
(Tabs A, B, C...)

Port Number

A54-3000-100 A

Description
Clicking a tab displays port names for the specified blade.
Tab letters match the blade numbers on your I NETELLAP ATCH
chassis. Blade labels use letters and start at the bottom. Port
labels use numbers prefaced by blade letter, and start at the left.
For details, see Switch Labeling on page 9.
Identifies the port whose name you want to change:
• To assign a name, type the name in the text box to the right of
the port number, then click the Update button.
• To clear a name, delete the name in the text box to the right of
the port number, then click the Update button.
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Field
Clear For This Blade
button
Save button
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Description
Deletes assigned names for all ports on this blade.
Saves and implements your changes.
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Classes
Sets up port classes and defines the properties of each port class.
Note
After setting up classes and assigning ports to those classes, you can quickly view and
modify settings for SPAN and Analyzer ports by accessing the Monitor screen. For more
information, see Chapter 5, MONITOR, starting on page 48.
To set up or change port classes and their properties, select:
Ports/Blades>Configuration>Classes
This screen displays on the Canvas:
Figure 23. Classes screen

Screen appearance
before checking the
checkbox

Details that display
after checking the
checkbox

Port classes

Port class mode

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Enforce port classes

Description
Determines how classes are used:
Checked: Enforce classes.

Edit port class
memberships
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Unchecked (default): Do not enforce classes.
Displays the port Class Members window. For details about this
window, see page 67.
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Field
Port Class 1–16
—or—
Names you specify

See

Port class mode

Save button
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Description
A name that both creates and identifies the port class. The default
name is Port Class n. Port class names consist of up to 31
characters and can include letters, numbers, spaces, and most
keyboard characters. Port class names cannot include these
characters:
< (Less-than symbol)
" (Quote marks)
> (Greater-than symbol)
' (Apostrophe)
\ (Backslash)
Fields that retain the name Port Class n or are blank are
not classes.
Note: If the first four letters of a class are SPAN, the INTELLAPATCH
switch assumes that ports assigned to the class are SPAN ports.
For details about setting up classes for SPAN ports, see Simplex
Patching with SPAN/Monitor Ports on page 13.
Lists all ports by class. When you click this link, the window
displays the class to the left of the link. You can scroll to display
all ports. Use this window to quickly view all ports included in
this class.
Restricts connections as follows:
• Inclusive classes (default): Allows ports to connect only when
they belong to the same class. When all port classes are
inclusive, ports not assigned a port class cannot connect to any
other port.
• Exclusive classes: Prevents ports of the same class from
connecting. When all port classes are exclusive, ports not
assigned a port class may patch to any other port.
Saves and implements your changes.
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Class Members
Assigns a port to a class.
To assign a port to a class, select:
Ports/Blades>Configuration>Class Members
This screen displays on the Canvas:
Figure 24. Class Members window

Tabs
Port
Classes

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Blade:
Tabs A, B, C ...)

Port
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Description
Clicking a tab displays the class settings for the specified blade.
Tab letters match the blade numbers on your I NETELLAP ATCH
chassis. Blade labels use letters and start at the bottom. Port
labels use numbers prefaced by blade letter, and start at the left.
For details, see Switch Labeling on page 9.
Identifies the port assignment. The port name consists of:
PortNumber:PortName
Where PortNumber is the number assigned to the port and
PortName is the name you specify. If you do not specify a port
name, Unnamed displays.
For information about naming ports, Port Properties on page 50.
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Field
Classes

Exit button
Save button
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Description
Assigns the port to a class or classes. This screen displays the
classes you specified on the Classes screen. Only the classes
display; fields named Port Class n or are blank are not classes
and therefore do not display.
To assign a port to a class:
1. Click the checkbox of the class you want to assign the port to.
2. Click the Save button.
Exits the Class Members screen without saving changes.
Saves and implements your changes.
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Port Locking
Reserves the specified port(s) for your exclusive use.
To access port locking options, select:
Ports/Blades>Configuration>Locking
This screen displays on the Canvas:
Figure 25. Port Locking screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Port Locking Enabled

Description
Specifies port locking capabilities:
(Enabled) Allows users to lock ports.

Maximum Lock Time

Disconnect on Expire?

(Disabled) Users cannot lock ports.
Specifies the lock duration:
• No Limit: The lock remains in effect until manually cleared.
• No more than n minutes: The lock remains in effect for only the
number of minutes specified.
Determines port behavior when the lock period expires:
(Checked) Locked ports disconnect.

Help
Save button
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(Unchecked) Locked ports remain connected.
Hovering your cursor over this icon displays Help information
about the associated field.
Clicking this button saves and implements your changes, then
displays the Port Locking screen.
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Zoning
Sets up zones and defines the properties of each zone.
To access zoning options, select:
Ports/Blades>Configuration>Zoning
This screen displays on the Canvas:
Figure 26. Zoning screen

Screen appearance
before checking the
checkbox

Details that display
after checking the
checkbox

Zones

Buttons

Zone listing

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Zoning enabled

Description
Determines how zones are used:
Unchecked (default): Disables zoning.

Zones
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Checked: Enables zoning.
Displays zones available on this switch. To create a zone:
1. Click the Add button. The Explorer User Prompt dialog box
displays.
2. Type a zone name, then click the OK button. The Edit Ports dialog
screen displays. For details about this screen, see Zoning: Edit
Ports Screen on page 71.
3. Select the ports you want to include in this zone, then click the
save button. The Zoning screen displays.
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Buttons

Zone listing
Tabs

Edit Ports dialog screen
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Description
The buttons on this screen perform the following actions:
• Edit Ports: Displays the Edit Ports dialog screen screen where you
can add or delete ports included in this zone. For details about
this screen, see Zoning: Edit Ports Screen on page 71.
• Edit Users: Displays the Edit User dialog box dialog box where you
can add or delete users included in this zone. For details about
this dialog box, see Zoning: Edit User Dialog Box on page 72.
• Add: Creates a new zone.
• Rename: Changes the name of a zone.
• Remove: Deletes a zone.
Displays the ports and users included in the specified zone.
Displays zone ports in the order you specify:
• View By Zone: Displays zones in alphabetical order and
indicates the ports, if any, assigned to each zone.
• View By User: Displays users in alphabetical order and
indicates the zone, if any, to which each is assigned.
• View By Port: Displays ports in ascending order and indicates
the zone, if any, to which each is assigned.

Zoning: Edit Ports Screen
Figure 27. Zoning: Edit Ports Screen

Zone details

The screen includes these options:
Field
Editing Zone:
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Description
Identifies the zone and serves as the link location when adding
ports to a zone. To add a port to a zone:
1. Select the port(s) you want to add using one of these methods:
• To add a port to a zone, place the cursor over the port’s
checkbox and click.
• To add a blade to a zone, click the Toggle link, located on the
right side of the screen.
2. Click the Save button.
Locked ports display as green, while unlocked ports remain gray.
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Field
Zone details

Toggle
Cancel button
Save button
Edit User dialog box

6.4.5.2.
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Description
Hovering your cursor over a port displays the following lock
information for that port:
• Port number: Port name: Identifies the port assignment.
PortNumber is the number assigned to the port and PortName is
the name you specify. If you do not specify a port name,
Unnamed displays.
For information about naming ports, Names on page 63.
• Belongs to zone(s): The zone to which this port is assigned. If
no name is specified a port name, (none) displays.
Checks or unchecks all ports on the selected blade.
Exits the Edit Ports screen without saving changes.
Clicking this button saves and implements your changes.

Zoning: Edit User Dialog Box
Figure 28. Zoning: Edit User Dialog Box

Zone

The dialog box includes these options:
Field
Zone
Users in zone:
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Description
The zone you selected on the Zoning screen.
Lists users assigned to the specified zone. RADIUS and
TACACS+ users are identified with an asterisk.
To add a user to this zone:
1. Select user(s) in the Users not in zone list. You can click to
select a single user, hold down the Alt button while clicking to
add multiple users, or hold down the Shift button while clicking
to add a range of users.
2. Click the <== Add button. The selected user names move to the
Users in zone list.
Note: The admin user is automatically added to all zones.
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Field
Users in zone: (cont’d)

Users not in zone:
<== Add button
Remove ==> button
<== Add RADIUS
button
Cancel button
Save button
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Description
To remove a user from this zone:
1. Select user(s) in the Users in zone list. You can click to select a
single user, hold down the Alt button while clicking to add
multiple users, or hold down the Shift button while clicking to
add a range of users.
2. Click the Remove ==> button. The selected user names move
to the Users not in zone list.
Lists users not assigned to the specified zone.
Adds the user(s) selected from the Users not in zone list.
Removes the user(s) selected from the Users in zone list.
Adds all RADIUS user(s) in the Users not in zone list.
Clicking this button exits the dialog box without saving
your changes.
Clicking this button saves and implements your changes.
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Receive Monitoring
To select ports you want to monitor for loss of signal, select:
Ports/Blades>Configuration>Receive Monitoring
This screen displays on the Canvas:
Figure 29. Receive Monitoring screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Ports

Deselect all
Select all
Save button
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Description
Clicking a port’s checkbox means that port is continuously
monitored for loss of signal. Ports not selected are not monitored.
To view monitor results, see the Alarms screen
(Ports/Blades>Configuration>Alarms>, described on page 61.
Un-selects all ports on the switch.
Selects all ports on the switch.
Clicking this button saves and implements your changes.
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Edit Presets
To set switches to a saved configuration, select:
Connections>Patching>Edit Presets
This screen displays on the Canvas:
Figure 30. Edit Presets screen

The screen includes these options.
Note
To make changes on this screen, your account must have a minimum of Advanced Operator
permission privileges. For details about permissions, see Permissions on page 112.
Field
Save Current Patches
As a Preset
Preset

Description
Saves or changes configuration settings to the preset name or
number you specify.
The Preset number whose configuration settings you want to save
or change. You can select a name or number from 1 to 99.
CAUTION: Selecting a position that already has configuration
settings assigned overwrites those settings without warning.
New Preset Name
A name you specify for the Preset. You can enter a name of up to
255 characters. Select names that provide meaningful aids to
memory, so that you can recall later how it configures the switch,
and so that others can understand its purpose.
Store Current button Saves the configuration settings to the Preset position you
specified.
Edit/Clear Preset
Clears (deletes) configuration settings for the preset name or
number you specify.
Preset drop-down
The Preset number you want to change. You can select a name or
menu
number from 1 to 99.
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Field
Clear button

Edit button
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Description
Clears the configuration settings of the Preset position you
specified.
Note: Clearing a preset is equivalent to changing all its settings to
n/c, or no change.
Displays a screen similar to the Realtime patching screen where
you can specify new configuration settings. For information about
this screen, see page 33.
Unique to the Edit Presets screen are the All ports options:
n/c Instructs WEBX to leave the current patch settings unchanged
when this preset configuration is invoked.
off Unpatches all ports.
loopback
Patches each port to itself, except SPAN ports.
Note: SPAN ports do not change when you select any of
these options.
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This chapter details the screens available from the View menu:
For information about...
Go to this page...
Controller ...................................................................................................................... 78
Event Log ...................................................................................................................... 82
Logged In ...................................................................................................................... 84
Display Options ............................................................................................................. 85
Show Toolbar ............................................................................................................. 85
Toolbar Text Labels ..................................................................................................... 85
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Controller
To see switch details such as name, model number, serial number, manufacture date, firmware
version, device number, network properties, and alarm status, selecte:
View>Chassis>Controller
This screen displays on the Canvas:
Figure 31. Controller screen

The screen includes these options:
Note
To view this screen, your account needs only Guest permission privileges. For details about
permissions, see Permissions on page 112.
Field
Chassis Model
Motherboard Model
Serial Number
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Description
The switch’s model number. This is a display-only field; you
cannot change its value.
The switch motherboard’s model number. This is a display-only
field; you cannot change its value.
The switch’s serial number. This is a display-only field; you
cannot change its value.
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Field
Manuf. Date
Firmware Version
Switch Name

Primary IP Address

Subnet Mask
Gateway
Device Number

Security

Port Classes
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Description
The switch’s manufacture date. This is a display-only field; you
cannot change its value.
The version number of firmware embedded in the switch. This is a
display-only field; you cannot change its value.
The name you specify for the switch. The default is Unnamed.
Clicking the Edit link, viewable only by users with Administrator
permission privileges, displays the Properties screen where you
can change the switch name. For details about this screen, see
page 133.
Note: You can also access this screen by selecting
Configuration>Switch Properties.
The IP address you specify for the switch. The default is
192.168.0.1.
Clicking the Edit link, viewable only by users with Administrator
permission privileges, displays the LAN Interface screen where
you can change the IP address. For details about this screen, see
page 129.
Note: You can also access this screen by selecting
Configuration>LAN Interface.
The subnet mask address you specify for the switch. The default
is 255.255.255.0.
The network gateway address you specify for the switch. The
default is to not use a gateway.
The device number you specify for the switch. The default is 1.
To change the device number, go to the ASCII (Slash) device number
option on the Service Properties screen. For details about this screen,
see page 117.
Indicates whether user authentication is required, and specifies
the type.
Clicking the Edit link, viewable only by users with Administrator
permission privileges, displays the User Database screen where
you can change the IP address. For details about this screen, see
page 107.
Note: You can also access this screen by selecting
Configuration>User Database.
Indicates whether you can specify or use port classes.
Clicking the Edit link, viewable only by users with Administrator
permission privileges, displays the Classes screen where you can
change the IP address. For details about this screen, see
page 65.
Note: You can also access this screen by selecting
Configuration>Port Classes.
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Field
Zoning

Port Locking

Power

Temperature

Power Supply n Alarm

SFP Warnings
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Description
Indicates whether you can specify or use zones.
Clicking the Edit link, viewable only by users with Administrator
permission privileges, displays the Zoning screen where you can
change the IP address. For details about this screen, see
page 70.
Note: You can also access this screen by selecting
Configuration>Zoning.
Indicates whether you can reserve specified ports exclusive use.
Clicking the Edit link, viewable only by users with Administrator
permission privileges, displays the Locks screen where you can
change the IP address. For details about this screen, see
page 54.
Note: You can also access this screen by selecting
Configuration>Port Locking.
Indicates whether power is supplied to the switch.
The ACI-2058, 288-port switch, includes three power supplies.
One is required to power on the motherboard. At least two must
function to fully power the unit, including the blades.
Other switches, such as the 144- and 64-port switches, include
two power supplies. Only one is required to power on the
motherboard and to fully power the unit.
Indicates temperature and status:
• Green: Internal temperature is within specified limits.
• Flashing red: Internal temperature exceeds the specified limit.
If this occurs, the switch also emits an audible alarm, if
enabled. For details, see Properties on page 133.
The default temperature’s maximum threshold is 50º C. To
change the default, click the Edit link, viewable only by users with
Administrator permission privileges and located to the right of
Switch Name, to display the Properties screen. For details about
this screen, see page 133.
Note: You can also access this screen by selecting
Configuration>Switch Properties.
Indicates operational status of the specified power supply.
• Green: The power supply is functioning normally.
• Flashing red/amber: The power supply failed. If this occurs, the
switch also emits an audible alarm if enabled. For details, see
Audible alarms enabled on page 138.
Indicates operational status of SFP temperature, power, and
received signal. Checks the transmit signal only if Automatic
Transmitter Disable is set to TX on when no RX. For details about
this option, see Properties on page 133.
• Green: The SFP is functioning within normal thresholds.
• Flashing red: One or more SFPs have exceeded the warning
threshhold defined by the SFP manufacturer. To determine
which SFP(s) failed, click the field label to display the Alarms
screen. For details about this screen, see page 61.
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Field
SFP Alarms

Message
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Description
Indicates operational status of SFP temperature, power, and
received signal. Checks the transmit signal only if Automatic
Transmitter Disable is set to TX on when no RX. For details about
this option, see Properties on page 133.
• Green: The SFP is functioning within normal thresholds.
• Flashing red: One or more SFPs have exceeded the alarm
threshhold defined by the SFP manufacturer. If this occurs, the
switch also emits an audible alarm. To determine which SFP(s)
and what alarm s encountered problems, click the field label to
display the Alarms screen. For details about this screen, see
page 61.
The system message, a message supplied by the administrator.
Clicking the Edit link, viewable only by users with Administrator
permission privileges and located to the right of Switch Name,
displays the Login Message screen where you can change the
system message. For details about this screen, see page 140.
Note: You can also access this screen by selecting
Data>Message.
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Event Log
Displays the 500 most recent system events that occurred since the most recent boot. This
log mirrors the remote syslog, described on page 120.
To view system events, select:
View>Chassis>Event Log
This screen displays on the Canvas:
Figure 32. Events screen

Refresh
interval

The screen includes these options:
Note
To view this screen, your account needs only Guest permission privileges. For details about
permissions, see Permissions on page 112.
Field
Refresh interval

Date/Time
Event
Blade
Port
Process
User
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Description
Specifies the amount of time that elapses before WEBX refreshes
the data. Valid values include
• No refresh (default): WEBX does not refresh the data.
• 10 seconds: Data automatically refreshes every ten seconds.
• 30 seconds: Data automatically refreshes every thirty seconds.
• 1 minute: Data automatically refreshes every minute.
• 5 minutes: Data automatically refreshes every five minutes.
Displays the date and time the event occurred.
Lists the event type.
Displays the letter of the blade on which the event occurred. If 0
(zero) displays, a blade was not involved in the event.
Displays the number of the port on which the event occurred. If 0
(zero) displays, no port was involved in the event.
Lists the program that caused the event to occur.
Displays the login name of the user associated with the event.
Includes an IP address only if the User is at a different address
than the process.
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Field
IP

Message
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Description
Lists the IP address, in standard TCP/IP #.#.#.# format, where
the process that caused the event runs. 127.0.0.1 indicates that
the process was running within the APCON switch. For example,
accessing APCONCMDX via Telnet versus the APCONCMDX
application running on a workstation.
Displays additional information about the event.
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Logged In
To view users currently logged in to the switch, select:
View>Chassis>Logged In
This screen displays on the Canvas:
Figure 33. Logged In screen

The screen includes these options:
Note
To view this screen, your account needs only Guest permission privileges. For details about
permissions, see Permissions on page 112.
Field
User
Address
Service
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Description
The user’s login name.
The IP address from which the user logged in.
The interface from which the user logged in. For example, Web or
CLI (including telnet and SSH).

84

APCON, Inc.

WEBX v2.50 User Manual

7.4.

Display Options

7.4.1.

Show Toolbar
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To toggle the toolbar display, select:
View>Chassis>Show Toolbar
You can choose one of these:
Checked (default): The Toolbar displays.
Unchecked: The Toolbar does not display.
For more information about the WEBX toolbar, see Toolbar on page 6.

7.4.2.

Toolbar Text Labels
To display menu option labels, select:
View>Chassis>Toolbar Text Labels
You can choose one of these:
Checked (default): Menu labels display.
Unchecked: Menu labels do not display.
For more information about WEBX menus, see Menus on page 7.
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This chapter details the screens available from the Tools menu:
For information about...
Go to this page...
Cable Test ..................................................................................................................... 87
Flapping ........................................................................................................................ 89
Signal Counters ............................................................................................................. 91
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Cable Test
Displays signal strength, in dBm and by color. You can use this screen to monitor
cable health.
To view or calibrate signal strength, select:
Tools>Diagnostics>Cable Test
This screen displays on the Canvas:
Figure 34. Cable Test screen

Signal
display

Color
calibration

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Signal display

Load/Reload links
Load All link
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Description
Displays the SFP’s RX signal strength in dBm and by color,
rounded to the nearest 0.05 mW, for each port on the
INTELLAPATCH switch.
Signal information does not display for the following:
• Transceivers that do not support signal display.
• Ports that do not have SFP modules installed.
• Blades that do not support SFP modules.
Selectively loads and updates signal data on a per-blade basis.
Select this option to quickly access signal data.
Loads and updates signal data for all blades on the switch. Select
this option when you need to see the data for all blades and time
is not an issue.
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Color calibration
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Description
Specifies the color that displays for various signal strengths.
Set the slider to the minimum signal strength required for
transmission. Check your transceiver manufacturer specifications
for acceptable signal strengths.
After you set the slider, signals display as follows:
• Green: The transceiver is receiving enough signal to properly
transmit.
• Red gradient: The transceiver is not receving enough signal to
properly transmit. The darker the color, the lower the signal.
• Black: The transceiver either does not receive signal or no
transceiver exists.
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Flapping
Specifies the ports whose signal you want to toggle to test for faulty or loose cable
connections.
To set up ports for signal flapping, select:
Tools>Diagnostics>Flapping
This screen displays on the Canvas:
Figure 35. Flapping screen

Ports

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Ports
Milliseconds to disable
the transmitter:
Milliseconds to enable
the transmitter:
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Description
Specifies the ports you want to test using port flapping. Locking
and zoning permissions apply.
The duration, in milliseconds, the transmitter is disabled. The
default is 100.
The duration, in milliseconds, the transmitter is enabled. The
default is 100.
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Field
Number of times to
repeat:

Start button
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Description
The number of times the disable/enable cycle repeats. The
default is x.
Note: The duration of the total test period cannot exceed 10
seconds.
Pressing the Start button saves your test settings and starts
the test.
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Signal Counters
Counts how many times the port’s signal starts and stops. WEBX updates the count every five
seconds, displaying a Loading... message in the upper left corner during updates. Use this
screen to troubleshoot cable integrity.
To count signal transitions, select:
Tools>Diagnostics>Signal Counters
This screen displays on the Canvas:
Figure 36. Signal Counters screen

Port number

Clear port count

Count

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Port number
Count

Clear port count
Clear All
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Description
Identifies the port whose transitions you want to count.
Displays the number of times signal has transitioned from on to
off or from off to on. The counter can record up to 16 million
transitions.
Resets the counter to 0 (zero) and restarts the count.
Resets all counters to 0 (zero) and restarts the count.
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This chapter details the screens available from the Maintenance menu:
For information about...
Go to this page...
Backup/Restore ............................................................................................................. 93
Backup Settings ......................................................................................................... 93
Backup Users ............................................................................................................ 96
Restore Settings ........................................................................................................ 97
Switch ........................................................................................................................... 98
License Key ............................................................................................................... 98
Reset ........................................................................................................................ 99
Upgrade Firmware .................................................................................................... 101
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9.1.1.

Backup Settings
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Exports switch configuration settings for use in another switch.
Once you export data, you can modify file content, provided you leave the formatting intact.
For information about this format, see Import/Export Settings File Format on page 146. You
should use only a text editor or scripts to make changes. A word processor adds additional
formatting which renders XML files invalid for importing.
Note
To import configuration settings, see Restore Settings on page 97.
To export switch configuration data, select:
Maintenance>Backup/Restore>Backup Settings
This screen displays on the Canvas:
Figure 37. Export screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
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Field
XML (conforms to
apconswitch.dtd)

Diagnostic XML

ASCII Commands

APCONCMDX / CLI2
Commands

CLI3 Commands
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Description
Instructs the switch to export the specified data in XML format.
For information about this format, see Import/Export File
Formats on page 147.
Note: If you plan to import this data to an INTELLAPATCH switch,
you must select this option. INTELLAPATCH switches accept
imported configuration data only in XML format.
Instructs the switch to export the specified data in Diagnostic XML
format. For information about this format, see Import/Export File
Formats on page 147.
Diagnostic XML is the same as XML, but includes SFP digital
diagnostic information, such as SFP serial and model number, in
the export. You can use this additional information to take
inventory of the SFPs in your INTELLAPATCH switch, and when
contacting APCON Technical Support.
Notes:
• Because this format takes significantly longer to export on
large switches with a great number of SFPs, use regular XML
unless you specifically need the digital diagnostic information.
• The extra fields in the Diagnostic XML format do not affect the
import. You can import settings with either a regular XML file or
a Diagnostic XML file; the extra diagnostic fields are simply
ignored.
Instructs the switch to export the specified data in plain text
(ASCII) format. For information about this format, see
Import/Export File Formats on page 147.
These commands can then be used directly in any custom scripts
that use the APCON Firmware Direct command set, also known as
ASCII.
Instructs the switch to export the specified data in APCONCMDX
format. For information about this format, see Import/Export File
Formats on page 147.
Once exported to APCONCMDX format, you can use the command
strings from within the telnet or SSH CLI or the APCONCMDX
command line utility.
Note: Use the exported file as a template when developing your
own scripts. Running the exported file without scrutiny may alter
settings, such as network your IP address, that may cause your
connection to drop.
Instructs the switch to export the specified data in APCON CLI3
format. For information about this format, see Import/Export File
Formats on page 147.
Once exported to APCON CLI3 format, you can use the command
strings from within the telnet or SSH CLI or the APCON CLI3
command line utility.
Note: Use the exported file as a template when developing your
own scripts. Running the exported file without scrutiny may alter
settings, such as network your IP address, that may cause your
connection to drop.
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Field
Plain Text INI

Comma-Delimited

HTML

Export Data button
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Description
Instructs the switch to export the specified data in plain text INI
(Legacy ApconControl) format. For information about this format,
see Import/Export File Formats on page 147.
This format follows the popular Windows style for configuration
files. This format is easier to review, but harder to use in a
scripting environment.
Instructs the switch to export the specified data in a commadelimited, spreadsheet-style format. For information about this
format, see Import/Export File Formats on page 147.
Instructs the switch to export the specified data in HTML table
format. For information about this format, see Import/Export File
Formats on page 147.
Implements the instructions. The switch writes the specified data
in the selected format to an output file or directly to the screen
where it can be saved or copied for pasting. You are prompted to
supply a filename and destination folder or directory into which to
write the file.
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Backup Users
To export the user database, select:
Maintenance>Backup/Restore>Backup Users
Note
Before importing user data, contact APCON as described in Contacting APCON on page 4 or on
the Help>About menu option.
This screen displays on the Canvas:
Figure 38. Backup Users screen

The screen includes these options:
Note
To view this screen, your account needs only Guest permission privileges. For details about
permissions, see Permissions on page 112.
Field
user password

Export button
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Description
Specifies the password for the currently logged in user. Unless
the User Database (see page 107) is set to None, you must
provide a valid password.
Prompts you for a destination, then exports the user database to
that destination.
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Restore Settings
Imports part or all of another switch’s configuration settings for use in your switch. Importing
switch settings quickly configures a switch in a manner the same as, or similar to, another.
Note
To export configuration settings, see Backup Settings on page 93.
To import switch configuration data, select:
Maintenance>Backup/Restore>Restore Settings
This screen displays on the Canvas:
Figure 39. Restore Settings screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
File to upload:

Upload button
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Description
Specifies the switch configuration file you want to upload.
You can do one of these:
• Enter the update file’s full directory path and filename.
• Click the Browse button to navigate to and select the file.
Note: Ensure that the file you plan to import is in XML format and
was previously exported using APCON WEBX or, if manually
created, the file strictly adheres to XML syntax. INTELLAPATCH
switches accept imported configuration data only in XML format.
For information about file format, see Import/Export File Formats on
page 147.
Clicking this button copies the specified file to the switch.
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Activates additional features available from APCON. For details about available features,
contact your APCON sales representative as described in Contacting APCON on page 4 or on
the Help>Support menu option.
To configure features, select:
Maintenance>Switch>License Key
This screen displays on the Canvas:
Figure 40. License Key screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Motherboard Serial #
Unlocked features
Locked features

Change button
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Description
The serial number of the INTELLAPATCH chassis. This is a
display-only field; you cannot change its value.
Lists currently unlocked features. This is a display-only field; you
cannot change its value.
Lists locked features. This is a display-only field; you cannot
change its value.
For information about accessing locked features, contact APCON
as described in Contacting APCON on page 4 or on the
Help>Support menu option.
Saves and implements the changes you specified.
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Reset
For troubleshooting or other purposes, you can use the options on this screen to:
•

Reset the switch to its factory default configuration.

•

Reboot the switch.

To access reset options, select:
Maintenance>Switch>Reset
This screen displays on the Canvas:
Figure 41. Reset screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Clear Patches
Uptime
Reboot Switch button
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Description
Disconnects all ports (unpatches all connections).
Displays the elapsed time, in days, hours, minutes, and seconds,
since the last boot.
Clicking this button reboots the switch without cycling power. Port
names, patches, and other details of the current configuration
remain unchanged.
APCON recommends that you avoid rebooting a switch. Reboot
only after firmware updates or if you experience software or
connectivity issues.
WARNING: Rebooting the switch disconnects all patch ports until
the switch fully reboots.

99

APCON, Inc.

WEBX v2.50 User Manual

Chapter 9: Maintenance

Field
Reset Configuration
button

Description
Clicking this button resets the switch to the factory default
configuration.
You must enter the password for the currently logged in user.
Unless the User Database (see page 107) is set to None, you must
provide a valid password.
Note: The switch’s IP address and and system message remain
unchanged.
Wipe Memory button
Clicking this button wipes (deletes) everything, including the
IP address and internal user database.
You must enter the password for the currently logged in user.
Unless the User Database (see page 107) is set to None, you must
provide a valid password.
Customers in high-security environments may find this useful
before passing the APCON switch (or the motherboard) to another
department or to the factory (e.g. for an RMA return, trade, or
upgrade.)
Clear HTTPS
Clicking this button deletes the SSL certificate required for secure
Certificate button
(HTTPS) logins. For information about creating this certificate,
see Certificates on page 125.
Clear SSH Keys button Clicking this button deletes the SSH key required for secure
command line communication. For information about creating this
certificate, see Certificates on page 125.
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Upgrade Firmware
Activates the service necessary to update switch firmware, and uploads the new firmware file
to complete the update.
To update the switch’s firmware, select:
CAUTION
Before updating firmware, make a backup copy of your current firmware. Most firmware
updates preserve user-settable parameters such as IP address and patch configurations,
but firmware updates can sometimes overwrite some of these.
Maintenance>Switch>Upgrade Firmware
This screen displays on the Canvas:
Figure 42. Update Firmware screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Upload service

File

Upload button
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Description
Does the following:
• Displays firmware upload status, either running or not running.
• Toggles the service between a running and not-running state.
To change the state, click the underlined link.
Specifies the file you want to upload.
You can do one of these:
• Enter the update file’s full directory path and filename.
• Click the Browse button to navigate to and select the file.
Clicking this button copies the specified file to the switch.
Note: Uploading and processing new firmware can take several
minutes. Check the browser’s progress bar at the bottom of the
screen to check update progress.
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After the firmware successfully updates, a message similar to this displays:
Upload accepted. About to process file...
File size is 3976389
Running system command: /apcon/flashinstaller '/tmp/upload.dat' 2
Verifying integrity of file
Found control block data
File looks okay
Tagging factory firmware as bootable (transaction start)
Writing kernel data
Erasing device /dev/mtd/1
Writing 653936 bytes to /dev/mtd/1
10% 20% 30% 40% 50% 60% 70% 80% 90% 100%
Verifying data was written successfully
Verify completed successfully
Writing root filesystem data
Erasing device /dev/mtd/2
Writing 3322197 bytes to /dev/mtd/2
10% 20% 30% 40% 50% 60% 70% 80% 90% 100%
Verifying data was written successfully
Verify completed successfully
Tagging new firmware as bootable (transaction complete)
Program complete, returning code 0
NOTE: You must now reboot the switch
EOF from child process

If you supplied an inappropriate or corrupted firmware file or if the upgrade does not succeed
for other reasons, a message similar to this displays:
Upload accepted. About to process file...
File size is 815473
Running system command: /apcon/flashinstaller '/tmp/upload.dat' 2
Verifying integrity of file
Bad control block (ApconROM not found)
EOF from child process
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This chapter details the screens available from the Settings menu:
For information about...
Go to this page...
Personalization ............................................................................................................ 104
Your Password ......................................................................................................... 104
Your Preferences ...................................................................................................... 105
Users/Security ............................................................................................................. 107
User Database ......................................................................................................... 107
Local Users ............................................................................................................. 110
Permissions ............................................................................................................. 112
SNMP v3 Users ....................................................................................................... 114
Services ...................................................................................................................... 116
Service Properties .................................................................................................... 117
SNMP Properties ..................................................................................................... 122
Certificates .............................................................................................................. 125
Switch ......................................................................................................................... 129
LAN Interface ........................................................................................................... 129
Date/Time ............................................................................................................... 131
Properties ................................................................................................................ 133
Login Message ........................................................................................................ 140
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10.1.

Personalization

10.1.1.

Your Password
Note
This screen is available only if User Database is set to Internal. For details about User
Database options, see User Database on page 107.
To change your password, select:
Settings>Personalization>Your Password
This screen displays on the Canvas:
Figure 43. Your Password screen

The screen includes these options:
Note
Accounts at all permission privilege levels can access this screen. For details about
permissions, see Permissions on page 112.
Field
User name
Current password
New password
Confirm by retyping
Save button
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Description
Displays the name you used at login. This is a display-only field;
you cannot change its value.
The password you want to change.
A password comprised of up to 64 characters. Passwords are
case sensitive.
The same password typed in the New password field. The switch
ensures that the passwords match before accepting the change.
Clicking this button saves and implements your changes.
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Your Preferences
To change your preferences, select:
Settings>Personalization>Your Preferences
This screen displays on the Canvas:
Figure 44. Your Preferences screen

The screen includes these options:
Note
Accounts at all permission privilege levels can access this screen. For details about
permissions, see Permissions on page 112.
Field
Default start page:
Menu system:
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Description
Specifies the first screen that displays when you log in to WEBX.
Specifies the menus you want to use:
• Basic:Displays available options with icons.
• Power user: Displays available options in a pull-down menu.
For details about the menus, see Menus on page 7.
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Description
Determines whether the Toolbar displays:
Checked (default): The toolbar displays.

Available Commands
Commands in Toolbar

Save button

A54-3000-100 A

Unchecked: The toolbar does not display.
For more information about the WEBX toolbar, see Toolbar on
page 6.
Lists all commands available to include in the toolbar. To select a
command, highlight it, then click the Add => button.
Lists all commands you selected for inclusion in the toolbar. You
can put up to ten commands in this toolbar.
To remove a command, highlight it, then click the <= Remove
button. To change the display order, highlight a command, then
click the Up or Down buttons to move the command to the location
you desire.
Clicking this button saves and implements your changes.
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To manage the user database, select:
Settings>Users/Security>User Database
This screen displays on the Canvas:
Figure 45. User Database screen

Displays only when
User Database is
set to Internal

Displays only when
User Database is
set to RADIUS
or TACACS+

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
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Field
User Database

Description
Specifies which user database to use:
• None: (Default) Does not use a user database or logins. Legacy
switches use this method.
• Internal: Uses the internal user database.
• RADIUS: Uses a RADIUS server on your local area network for
user authentication.
• TACACS+: Uses a TACACS+ server on your local area network
for user authentication.
Note: If your RADIUS or TACACS+ server goes down, you can still
access the switch through the admin account, which acts as a
local administrator. For more information, see User Database
Concepts on page 11.
Default New User Level Specifies the default permission, or access level, for new
user accounts:
• Guest: Users with this permission level have read-only access.
This is the lowest permission level.
• Operator: Users with this permission level can do all that Guestlevel users can do, plus patch ports using only preset
configurations.
• Advanced Operator: Users with this permission level can do all
that Operator-level users can do, plus patch ports on an ad-hoc
basis, change rates and port names, plus save configuration
settings (“presets”).
• Administrator: Users with this permission level do everything
that the other levels do, plus set switch, blade, port, and other
information as well as set and clear user and security
information. This is the highest permission level.
These options are available only if User Database is set to
Internal, RADIUS, or TACACS+.
Numeric IP
Specifies the IP address for the specified RADIUS or TACACS+
(blank for none):
server on your local area network that contains the user database.
Notes:
• I NTELLAP ATCH switches support up to three RADIUS or
TACACS+ servers. For details, see User Database Concepts on
page 11.
• This option displays only if User Database is set to RADIUS
or TACACS+.
Specifies the password or phrase shared between the switch and
Shared secret
(ASCII text)
the specified RADIUS or TACACS+ server. This value must match
the value set for the INTELLA P ATCH switch on your RADIUS or
TACACS+ server.
Notes:
• I NTELLAP ATCH switches support up to three RADIUS or
TACACS+ servers. For details, see User Database Concepts on
page 11.
• This option displays only if User Database is set to RADIUS
or TACACS+.
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user ’s password

Save button
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Description
Confirms the password of the currently logged in user. Unless the
User Database (see page 107) is set to None, you must provide a
valid password.
Saves and implements your changes.
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Local Users
To manage user accounts, select:
Settings>Users/Security>Local Users
You can also access this pane by selecting Configuration>User Levels, then clicking the User
Management option.
Note
This screen is available only if User Database is set to RADIUS, TACACS+, or Internal. For
details about specifying a user database, see User Database on page 107.
One of these screens display on the Canvas:
Figure 46. Local Users screen

Displays when User
Database is set to
RADIUS or TACACS+

Displays when User
Database is set
to Internal

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
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Field
Login name

Password

Retype password:

Permission

user ’s password

Create button
Edit existing users

Edit Security Levels
[Change user security
levels]
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Description
Specifies the new account name. Account names are not
case-sensitive. Account names can include underscores or
hyphens, but cannot include spaces or special characters.
Specifies the password required for the user of this account to log
in. A password can consist of up to 64 characters, and can include
any keyboard character, including special characters. Passwords
are case sensitive.
This option displays only if User Database is set to Internal.
Type the password again in this box for confirmation. The switch
ensures that the passwords match before accepting the password.
This option displays only if User Database is set to Internal.
Specifies the permission, or access level, for each user:
• Guest: Users with this permission level have read-only access.
This is the lowest permission level.
• Operator: Users with this permission level can do all that Guestlevel users can do, plus patch ports using only preset
configurations.
• Advanced Operator: Users with this permission level can do all
that Basic Operator-level users can do, plus patch ports on an
ad-hoc basis, change rates and port names, plus save
configuration settings (“presets”).
• Administrator: Users with this permission level do everything
that the other levels do, plus set switch, blade, port, and other
information as well as set and clear user and security
information. This is the highest permission level.
Specifies the password for the currently logged in user. Unless
the User Database (see page 107) is set to None, you must provide
a valid password.
Creates a new user with the login name and permission level you
specified.
Specifies, by Login name, the user you whose account profile you
want to change. You can either change the password or delete the
account.
Clicking the Proceed button to the right of this text box saves
your changes.
Displays the User Levels screen where you can quickly change
the permission level of one or many users. For more information
about this screen, see Permissions on page 112.
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Permissions
Note
These permissions are only for Internal users. If using RADIUS or TACACS+, you must set
permissions in your Authentication server. For information about user types, see User
Database on page 107.
To manage user accounts, select:
Settings>Users/Security>Persmissions
You can also access this pane by selecting Configuration>User Management, then clicking
the change user security levels option.
This screen displays on the Canvas:
Figure 47. Permissions screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see the next table.
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Field
Login name
Permission level

user ’s password

Save button
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Description
Identifies the user by Login name. This is a display only field; you
cannot change its value.
Specifies the permission, or access level, for each user:
• Guest: Users with this permission level have read-only access.
This is the lowest permission level.
• Operator: Users with this permission level can do all that
Guest-level users can do, plus patch ports using only preset
configurations.
• Advanced Operator: Users with this permission level can do all
that Basic Operator-level users can do, plus patch ports on an
ad-hoc basis, change rates and port names, plus save
configuration settings (“presets”).
• Administrator: Users with this permission level do everything
that the other levels do, plus set switch, blade, port, and other
information as well as set and clear user and security
information. This is the highest permission level.
Specifies the password for the currently logged in user. Unless
the User Database (see page 107) is set to None, you must provide
a valid password.
Saves and implements your changes.
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SNMP v3 Users
To xyz select:
Settings>Users/Security>SNMP v3 Users
This screen displays on the Canvas:
Figure 48. SNMP v3 Users screen

The screen includes these options:
Note
Accounts at all permission privilege levels can access this screen. For details about
permissions, see Permissions on page 112.
Field
Description
Create a new SNMPv3 user
Security name:
Specifies the SNMP USM user name.
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Field
Authorization Type:

Description
Specifies the encryption method used for authorization. Values
include:
• MD5
• SHA
Password:
Specifies the SNMP auhorization passphrase.
Privacy Type:
Specifies the encryption method used for communication. Values
include:
• None
• AES
• DES
Password:
Specifies the SNMP privacy passphrase.
Retype Password:
Type the password again in this box for confirmation. The switch
ensures that the passwords match before accepting the password.
Permission:
Specifies the default permission, or access level, for new
user accounts:
• Guest: Users with this permission level have read-only access.
This is the lowest permission level.
• Operator: Users with this permission level can do all that Guestlevel users can do, plus patch ports using only preset
configurations.
• Advanced Operator: Users with this permission level can do all
that Operator-level users can do, plus patch ports on an ad-hoc
basis, change rates and port names, plus save configuration
settings (“presets”).
• Administrator: Users with this permission level do everything
that the other levels do, plus set switch, blade, port, and other
information as well as set and clear user and security
information. This is the highest permission level.
These options are available only if User Database is set to
Internal, RADIUS, or TACACS+.
user password:
Specifies the password for the currently logged in user. Unless
the User Database (see page 107) is set to None, you must provide
a valid password.
This field is required only for changes to the SNMP user database.
Create button
Adds a user account to the SNMP user database.
Delete existing SNMPv3 user
Select user:
Lists all users in the SNMP user database. To select a user for
deletion, highlight that user, enter your password, then click the
Delete button. To select more than one user, press the Ctrl key as
you select users. To select a block of users, press the Shift key,
then select the first and last user in the block.
user password:
Specifies the password for the currently logged in user. Unless
the User Database (see page 107) is set to None, you must provide
a valid password.
This field is required only for changes to the SNMP user database.
Delete button
Deletes selected users from the SNMP user database.
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Services
With WEBX, you can perform the following switch security tasks:

A54-3000-100 A

•

Enable secure web (HTTPS) connections, requiring users to log in using a secure SSL
connection. You can also generate the SSL certificate required to enable secure SSL
logins.

•

Enable secure command line (CLI) connections, allowing users to log in using an SSH
connection. You can also generate the SSH key required to enable SSH.

•

Enable one or more users to issue ASCII commands or run ASCII-command scripts over
the network.

•

Enable network use of TITAN.

•

Enable network use of CLI, APCON’s Telnet interface, as a secure Telnet (SSH)
connection. You can also generate an SSH key to run CLI in secure mode.

•

Enable the use of telnet, TFTP, RPC, Secure RPC, SNMP, and remote syslog.
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Service Properties
To manage switch security, select:
Settings>Services>Service Properties
This screen displays on the Canvas:
Figure 49. Service Properties screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
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Field
Force secure (HTTPS)
logins

Web session inactivity
timeout
Enable SSH
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Description
Specifies the types of logins allowed:
Unchecked (default): Allows both HTTP (insecure) and
HTTPS (secure) logins.
Checked: Allows only HTTPS (secure) logins.
Note: Valid only if an SSL certificate exists and the certificate is
linked to the correct IP address.
Specifies the number of minutes or hours of inactivity that elapse
before WEBX automatically logs out a user.
Specifies the types of logins allowed:
Unchecked (default): Does not allow SSH (secure) logins.

Checked: Allows SSH (secure) logins.
Note: SSH provides a channel you can use to communicate with
the switch and encryption. If you do not require the security of
encryption, you can also consider using insecure telnet
connections.
ASCII Command
Configures ASCII command behavior and their network
Configuration
availability.
ASCII (Slash) device Enter a number from 1 to 32 that indicates the ASCII device
number
number. The factory default is 1 (one). Do not change this number
unless you plan to daisy chain the switch or use it with
INTELLAZONE.
Enable ASCII (Slash) Determines ASCII (slash) command availability:
commands over
Unchecked (default): The ASCII (Slash) commands are not
network
enabled or available over the network.
Checked: Users can use the ASCII (Slash) commands over
the network.
ASCII (Slash) commands are used to run scripts or issue
commands that use the ASCII command set. To get ASCII (Slash)
command documentation, contact APCON as described in
Contacting APCON on page 7.
Enable simultaneous Determines ASCII (slash) command availability:
ASCII commands
Unchecked (default): Only one user at a time can access the
ASCII (Slash) commands over the network.

ASCII (Slash)
timeout
Serial Port
Configuration
Serial port settings
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Checked: Multiple users can simultaneously access the
ASCII (Slash) commands over the network.
Note: This option displays only when the Enable ASCII (Slash)
commands over network option is checked.
Specifies the number of minutes with no activity that elapse before
ASCII commands are no longer available over the network. Select
the number of minutes, from 1 to 10, from the drop-down list.
Configures serial port behavior.
Specifies the number of stop bits used by the switch’s serial port.
The default is 1 stop bit. All other serial port settings are fixed:
9600 baud, 8 data bits, no parity, no flow control.
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Serial port
responds with

Other Services
Enable telnet
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Description
Specifies the software that runs on the serial port. Valid values
include:
• CLI [default]: To access the switch, users must enter CLI
commands.
• ASCII (Slash) commands: To access the switch, users must
enter ASCII commands.
Configures the behavior of network services.
Determines telnet availability:
Unchecked (default): CLI, APCON’s embedded telnet
interface, is not available over the network. Users must use
other methods to access the switch.

CLI (telnet/SSH
timeout, in minutes)
CLI version
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Checked: Users can now access the switch over the network
using CLI, APCON’s telnet interface.
Note: Telnet provides a channel you can use to communicate with
the switch, but does not provide encryption. If you require the
security of encryption, use SSH.
Specifies the number of minutes of inactivity that must elapse
before automatically terminating a telnet or SSI session. The
default is 5 (five) minutes. The maximum is 1440 minutes.
Specifies the CLI version you want to use:
• v2: Supports version 2 of the embedded CLI. Select this option
if you are running firmware version 2.11 or earlier, or if your
existing scripts were developed using this version.
Previous firmware that shipped with a CLI (most, if not all of the
existing “200 series” of firmware) shipped with this version,
which uses the same inputs and outputs as CLI.
• v3 (default; recommended): Supports version 3 of the
embedded CLI. Select this option if you are running firmware
version 2.12 or later.
WEBX 2.12 introduces this version, which includes features
such as user maintenance, zoning, locking, and port classes.
Although it tries to be backward compatible with v2, it may not
perfectly emulate all commands, which is why v2 is also
provided.
Note: Upgraded switches default to v2 to maintain compatibility
until the administrator explicitly switches to v3.
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Description
Determines TFTP availability:
Unchecked (default): Users cannot import and export
switch settings.
Checked: Users can now import and export switch settings.
Note: For security reasons, APCON recommends that you
enable the service only during short windows such as
installing a new switch with predefined parameters or
backing up an existing switch configuration as the TFTP
protocol itself does not support authentication.
When you select this option, you can access these files:
/tmp/export.xml (READ-ONLY)
Contains the current switch settings
/tmp/import.xml (WRITE-ONLY)
Upon successful upload, the switch is reconfigured
using the contents of this file. Depending on what
parameters are defined in the XML, the configuration
can take up to two minutes, during which time the
switch may beep or flash (e.g. when a blade is being
configured, powered on/off, or port rates are set.)

Enable SNMP

Enable RPC

Because this batch process runs in the background,
you cannot check status or completion (except to view
switch settings and verify that they change).
Clicking the Enabled or Disabled link to the right displays the
SNMP Properties screen where you set SNMP criteria. For details
about this screen, see page 122.
Determines RPC status:
Checked (default): RPC is enabled and available over the
network. You can now access and control the switch over the
network using standalone software applications such as
APCON’s TITAN software.

Enable Secure RPC

Unchecked: RPC is not available over the network. Users
must use other methods to access the switch.
Note: Use the default value unless directed otherwise by APCON
support personnel.
Determines Secure RPC status:
Checked (default): Secure RPC (SSL) is enabled and
available over the network.

remote syslog

Enable remote
syslog

Unchecked: Secure RPC is not available over the network.
Users must use other methods to access the switch.
Note: Use the default value unless directed otherwise by APCON
support personnel.
Determines whether log events are sent to a central log server:
Checked (default): Send remote system log events.
Unchecked: Do not send remote system log events.
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Field
Send events to
this IP

Facility/Severity

Help
Save button
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Description
Specifies the IP address you want to send remote system log
events to, in standard TCP/IP #.#.#.# format.
Note: This option displays only when the Enable remote syslog
option is checked.
Specifies the event type and importance. You can select from the
following:
Facility
Severity
Core
Services
Local
0 Emergency
0 kernel
5 syslogd 16 local0
1 Alert
1 user
6 lp
17 local1
2 Critical
2 mail
7 news
18 local2
3 Error
3 system
8 UUCP
19 local3
4 Warning
4 security
9 clock
20 local4
5 Notice
10 security 21 local5
6 Informational
11 FTP
22 local6
7 Debug
12 NTP
23 local7
13 log audit
14 log alert
15 clock
Note: This option displays only when the Enable remote syslog
option is checked.
Hovering your cursor over this icon displays Help information
about the associated field.
Saves and implements your changes.
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SNMP Properties
APCON provides a Management Information Base (MIB) you can use in conjunction with an
SNMP management tools (such as OpenView) to manage INTELLAPATCH switches via Simple
Network Management Protocol (SNMP). WEBX supports only SNMP versions 1 and 2.
To use the MIB, you set the options in this screen and point your SNMP management
application to the INTELLAPATCH switch. You can then use your SNMP management
application to monitor and manage your INTELLAPATCH switch(es).
Note
These tools provide read-only access. Write permission requires SNMP v3, which requires
a license key from APCON. For more information about SNMP v3, see SNMP v3 Users on
page 114. For information about license keys, see License Key on page 98.
For more information about SNMP and APCON’s MIB files, see Appendix B, Adding APCON
Attributes to your RADIUS Server.
To configure WEBX SNMP settings, select:
Settings>Services>SNMP Properties
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This screen displays on the Canvas:
Figure 50. SNMP Configuration screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Enable SNMP
Informational Strings
system.sysDescr
system.sysName
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Description
Checking this box enables Simple Network Monitoring Protocol
(SNMP).
These fields specify how the switch identifies itself.
The switch’s model number. This is a display-only field; you
cannot change its value.
The name you specify for the switch. Clicking the Edit link displays
the Properties screen where you can change the switch name. For
details about this screen, see page 133.
Note: You can also access this screen by selecting
Configuration>Switch Properties.
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Field
system.sysLocation

system.sysContact

Public Communities
(SNMP v1/v2c readonly access)
Community Strings
1&2
Network Restriction
1&2

Trap Notifications
Trap IP Address
Trap Community
String
MIB Files
View of APCON
MIB tree
Download APCON
MIBs
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Description
A name you specify for the switch location. Select names that
provide meaningful aids to memory, so that you and others can
identify later the switch location.
Information you specify as a contact for the switch. You can
include names, phone numbers (including extenstions), email
addresses, or any other useful contact information.
The community with read-only access. Use this community to
monitor switch events.
The string required for community access. The switch includes
this string in outgoing public messages.
The subnet of machines allowed to access the corresponding
SNMP community. Valid values include:
• A subnet in IP/numbits format ( #.#.#.#/n)
Examples:
10. 1. 1.1/32
Only the specified host can access the community.
10. 1. 1.0/24
Any host in the 10.1.1.* Class C subnet can access
the community.
• default. Selecting this value opens access to all.
These fields specify how to handle event report messages, also
known as traps. Traps include only alarm events.
The IP address, in standard TCP/IP #.#.#.# format, of the SNMP
management application.
The string required for trap community access. The switch
includes this string in outgoing trap messages.
Provides access to APCON’s MIB file.
Displays APCON’s MIB tree in a formatted, human-readable format.
Downloads the APCON’s MIB file in archived text format. You can
then feed this file to your SNMP management application.
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Certificates
To change your preferences, select:
Settings>Services>Certificates
This screen’s Generate tab displays on the Canvas.

10.3.3.1.

Certificates screen: Generate tab
Generates self-signed SSL certificates and SSH keys.
Figure 51. Certificates screen

The screen includes these options:
Note
Accounts at all permission privilege levels can access this screen. For details about
permissions, see Permissions on page 112.
Field
Description
Current SSL Certificate Displays the current SSL certificate. The contents of the SSL
certificate change each time you generate a new SSL certificate.
Generate SSL
Creates a self-signed SSL certificate.
Certificate button
SSL certificates are based in part on the switch’s IP address.
Each time you change the switch’s IP address, you must generate
a new SSL certificate.
SSL certificates are required to log in to the switch using a secure
(HTTPS) connection. For information about secure logins, see
Logging In on page 23. For information about deleting this
certificate, see Reset on page 99.
Note: The switch may not respond until the new certificate is
generated. This process can take up to several minutes.
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Generate SSH Key
button
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Description
Displays the current SSH key. The contents of the SSH key
change each time you generate a new SSH key.
Creates an SSH key.
SSH key are based in part on the switch’s IP address. Each time
you change the switch’s IP address, you must regenerate a new
SSH key.
SSH key are required to log in to the switch using a secure telnet
(SSH) connection. For information about deleting this key, see
Reset on page 99.
Note: The switch may not respond until the new key is generated.
This process can take up to several minutes.

Certificates screen: Upload Web Cert tab
Generates custom certificates. To use these options, you must have corporate
certificate authority.
Figure 52. Certificates screen

The screen includes these options:
Note
Accounts at all permission privilege levels can access this screen. For details about
permissions, see Permissions on page 112.
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Field
CA public certificate,
*.PEM format:
Apcon switch public
certificate, *.PEM
format:
Apcon switch private
certificate, *.PEM
format:
Upload button
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Description
A text box where you paste the copied CA public certificate.
A text box where you paste the copied APCON switch public
certificate.
A text box where you paste the copied APCON switch private
certificate.
Uploads the custom certificate(s) you specified.
Note: The switch may not respond until the new key is generated.
This process can take up to several minutes.

Certificates screen: Upload SSH Keys tab
Uploads a premade host key.
Figure 53. Certificates screen

The screen includes these options:
Note
Accounts at all permission privilege levels can access this screen. For details about
permissions, see Permissions on page 112.
Field
Description
The SSH keyfile upload Specifies the host key file you want to upload.
server is:
You can do one of these:
• Enter the update file’s full directory path and filename.
• Click the Browse button to navigate to and select the file.
Upload button
Clicking this button copies the specified file to the switch.
Text box
Displays the host key file after upload.
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Certificates screen: Download tab
Downloads certificates and keys from WEBX.
Figure 54. Certificates screen

The screen includes these options:
Note
Accounts at all permission privilege levels can access this screen. For details about
permissions, see Permissions on page 112.
Field
Description
SSL Keys and Certificates
CA public certificate, Displays a dialog where you can download the CA public
PEM format
certificate from WEBX to the workstation you specify.
public certificate,
Displays a dialog where you can download the public certificate
PEM format
from WEBX to the workstation you specify.
private key, PEM
Displays a dialog where you can download the private certificate
format
from WEBX to the workstation you specify.
SSH Host Key
host key, binary
Displays a dialog where you can download the host key from
format
WEBX to the workstation you specify.
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To configure network parameters, select:
Settings>Switch>LAN Interface
This screen displays on the Canvas:
Figure 55. LAN Interface screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Primary IP Address
MAC Address
IP Address

Subnet Mask

Gateway
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Description
Provides network information related to the primary IP address.
The switch’s MAC address. This is a display-only field; you cannot
change its content.
The switch’s IP address. The default is:
192.168.0.1
Set this value to an available static IP address on your network.
The switch’s subnet mask. The default is:
255.255.255.0
Your INTELLAPATCH switch requires a static IP address; DHCP is
not supported.
(Optional) The switch’s gateway address. To disable the network
gateway, leave this field blank, which means “none”. The default is
blank.
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Field
Enable secondary IP
address

IP Address

Subnet Mask

Gateway

Save button
Help
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Description
Determines how many IP addresses the switch uses:
(Checked): The switch uses two IP addresses. Each LAN
port is multihomed with the two IP addresses. The two LAN
ports on the back of the unit are split into isolated VLAN
segments and cannot pass traffic between each other. You
can reach each port by either IP address, but cannot
daisy chain.
(Unchecked): The switch uses one IP address. You can
stack multiple chassis together, plug one into the network,
and daisy-chain the rest.
For more information about single vs. dual IP addresses, see
Assigning IP Addresses on page 10.
The switch’s second IP address. The default is:
192.168.0.1
Set this value to an available static IP address on your network.
The switch’s second subnet mask. The default is:
255.255.255.0
Your INTELLAPATCH switch requires a static IP address; DHCP is
not supported.
(Optional) The switch’s second gateway address. To disable the
network gateway, leave this field blank, which means “none”. The
default is blank.
Saves the changes you specified.
Hovering your cursor over this icon displays Help information
about the associated field.
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Date/Time
To configure switch date and time, select:
Settings>Switch>Date/Time
This screen displays on the Canvas:
Figure 56. Date/Time screen

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
NTP Server

Description
Obtains the date and time from the NTP server, re-synchronizing
every hour. If you select this option, you cannot manually set
the time.
Note: Changing the NTP settings temporarily disconnects network
services such as telnet and SSH.
Server IP Address
The IP address of your network NTP server, in standard TCP/IP
#.#.#.# format.
Manual
Obtains the date and time from the source you specify. If you
select this option, you cannot obtain the date and time from the
NTP server.
Date (MM/DD/YYYY) Sets the switch date. Enter the time in the following format:
MM/DD/YYYY
MM Two digits that indicate the month.
DD

Two digits that indicate the day.

YYYYFour digits that indicate the year.
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24-Hour Time
(HH:MM)
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Description
Sets the switch time. Enter the time in 24-hour format:
HH:MM
HH Two digits that indicate the hour.

Two digits that indicate the minute.
Sets the time to one of these:
• Local: Uses the date and time reported by your web browser in
the Date and 24-Hour Time fields.
• GMT: Uses Greenwich Mean Time in the Date and 24-Hour
Time fields.
Saves the changes you specified.
Hovering your cursor over this icon displays Help information
about the associated field.
MM

Set To Browser Time

Save button
Help
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Properties
To configure switch characteristics, select:
Settings>Switch>Properties
Note
You can also access this screen from the Switch Details screen, as described on page 18.
This screen displays on the Canvas:
Figure 57. Properties screen

The screen includes these options:
Note
• To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
• Changing the settings on this screen may temporarily disrupt port signals.
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Field
Switch name

Description
A name that identifies the switch. The default name is Unnamed.
Switch names are up to 31 characters and can include letters,
numbers, spaces, and most keyboard characters. Switch names
cannot include these characters:
< (Less-than symbol)
> (Greater-than symbol)
\ (Backslash)
Fiber Optic Blades
Options in this section specify behavior for Fiber Optic blades.
Note: INTELLAPATCH products do not negotiate links in the way a
Layer 2/3 switch does. The ACI-2059-E16-2/S15-2 and ACI-2059E16-4/S15-4 blades are the only exception, as they each have a
PHY chip and do negotiate a link with the end device.
ACI-2059-F16-5 auto Specifies rate negotiation for the F16-5 blades on the switch:
rate negotiation
Unchecked: Transmission rates are set as specified on the
Rates screen, as described on page 52. Under most
conditions, this option is preferred.
Checked: Each port tries to lock onto the negotiated data
rate of the peripherals, HBAs, and switches physically cabled
to the INTELLAPATCH switch. Check the box only when this
feature is needed as it may decrease system performance.
Note: Selecting this option requires that you also set the
port’s data rate to Auto. For details, see Rates on page 52.
Failure to use this rate may result in incorrect data rates
displaying for some ports on the Patch Ports, Realtime
screen. For information about this screen, see Realtime on
page 33.
ACI-2059-F16-6 auto Specifies rate negotiation for the F16-6 blades on the switch:
rate negotiation
Unchecked: Transmission rates are set as specified on the
Rates screen, as described on page 52. Under most
conditions, this option is preferred.
Checked: Each port tries to lock onto the negotiated data
rate of the peripherals, HBAs, and switches physically cabled
to the INTELLAPATCH switch. Select this option only when this
feature is needed as it may decrease system performance.
Note: Selecting this option requires that you also set the
port’s data rate to Auto. For details, see Rates on page 52.
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Field
Switch name

Description
A name that identifies the switch. The default name is Unnamed.
Switch names are up to 31 characters and can include letters,
numbers, spaces, and most keyboard characters. Switch names
cannot include these characters:
< (Less-than symbol)
> (Greater-than symbol)
\ (Backslash)
Fiber Optic Blades
Options in this section specify behavior for Fiber Optic blades.
Note: INTELLAPATCH products do not negotiate links in the way a
Layer 2/3 switch does. The ACI-2059-E16-2/S15-2 and ACI-2059E16-4/S15-4 blades are the only exception, as they each have a
PHY chip and do negotiate a link with the end device.
ACI-2059-F16-5 auto Specifies rate negotiation for the F16-5 blades on the switch:
rate negotiation
Unchecked: Transmission rates are set as specified on the
Rates screen, as described on page 52. Under most
conditions, this option is preferred.
Checked: Each port tries to lock onto the negotiated data
rate of the peripherals, HBAs, and switches physically cabled
to the INTELLAPATCH switch. Check the box only when this
feature is needed as it may decrease system performance.
Note: Selecting this option requires that you also set the
port’s data rate to Auto. For details, see Rates on page 52.
Failure to use this rate may result in incorrect data rates
displaying for some ports on the Patch Ports, Realtime
screen. For information about this screen, see Realtime on
page 33.
ACI-2059-F16-6 auto Specifies rate negotiation for the F16-6 blades on the switch:
rate negotiation
Unchecked: Transmission rates are set as specified on the
Rates screen, as described on page 52. Under most
conditions, this option is preferred.
Checked: Each port tries to lock onto the negotiated data
rate of the peripherals, HBAs, and switches physically cabled
to the INTELLAPATCH switch. Select this option only when this
feature is needed as it may decrease system performance.
Note: Selecting this option requires that you also set the
port’s data rate to Auto. For details, see Rates on page 52.
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Field
Switch name

Description
A name that identifies the switch. The default name is Unnamed.
Switch names are up to 31 characters and can include letters,
numbers, spaces, and most keyboard characters. Switch names
cannot include these characters:
< (Less-than symbol)
> (Greater-than symbol)
\ (Backslash)
Fiber Optic Blades
Options in this section specify behavior for Fiber Optic blades.
Note: INTELLAPATCH products do not negotiate links in the way a
Layer 2/3 switch does. The ACI-2059-E16-2/S15-2 and ACI-2059E16-4/S15-4 blades are the only exception, as they each have a
PHY chip and do negotiate a link with the end device.
ACI-2059-F16-5 auto Specifies rate negotiation for the F16-5 blades on the switch:
rate negotiation
Unchecked: Transmission rates are set as specified on the
Rates screen, as described on page 52. Under most
conditions, this option is preferred.
Checked: Each port tries to lock onto the negotiated data
rate of the peripherals, HBAs, and switches physically cabled
to the INTELLAPATCH switch. Check the box only when this
feature is needed as it may decrease system performance.
Note: Selecting this option requires that you also set the
port’s data rate to Auto. For details, see Rates on page 52.
Failure to use this rate may result in incorrect data rates
displaying for some ports on the Patch Ports, Realtime
screen. For information about this screen, see Realtime on
page 33.
ACI-2059-F16-6 auto Specifies rate negotiation for the F16-6 blades on the switch:
rate negotiation
Unchecked: Transmission rates are set as specified on the
Rates screen, as described on page 52. Under most
conditions, this option is preferred.
Checked: Each port tries to lock onto the negotiated data
rate of the peripherals, HBAs, and switches physically cabled
to the INTELLAPATCH switch. Select this option only when this
feature is needed as it may decrease system performance.
Note: Selecting this option requires that you also set the
port’s data rate to Auto. For details, see Rates on page 52.
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Description
Specifies the duration, in tenths of seconds, a port’s transmitter is
turned off when re-patching a port without first un-patching it. The
port repatches with its transmitter off. Then, after the specified
time elapses, the transmitter turns back on.
This setting is required in environments where ports are not
always unpatched before repatching. It primarily affects end
devices that require a certain amount of time for the transmitter to
turn off before the link is forced to renegotiate which in turn
guarantees that new devices will be recognized.
INTELLAPATCH switches can patch ports as quickly as 100µs, often
resulting in devices not recognizing that a change in the physical
layer occurred, and therefore not renegotiating new devices.
Instead, the old devices are still recognized even though they are
no longer physically attached.
0.0 (Default) Transmitter is always on during port patching and
un-patching.
0.1–4.0
Specifies the duration, in tenths of seconds, that the
transmitter is turned off when re-patching previously
connected ports. Select a value long enough to satisfy the
protocol specification for forcing a link to renegotiate.
Determines action taken when transceiver faults are detected:
Some SFP transceivers support the MSA laser eye safety circuit
specification. Many conditions can trigger the laser eye safety
circuit, including high laser power, high laser bias current, high or
low voltage, and high or low temperature.
Unchecked (default): If the laser eye safety circuit is
triggered, the transmitter turns off.
If you select this option, turning a transmitter back on
requires manual intervention: physically unplugging the fiber
optic cable, re-seating it, re-seating the SFP transceiver, and
then power-cycling the blade or chassis.

Checked: The INTELLAPATCH switch actively monitors the
transceivers, checking SFPs for a fault every five seconds.
If a fault is detected, the laser eye safety circuit is reset
which turns the transmitter back on. If the condition that
caused the failure is still present, the fault is triggered again
and the transmitter may potentially stay off until the condition
is corrected.
Copper Ethernet Blades Options in this section specify behavior for Copper Ethernet
blades.
(ACI-2059-E16-2 /
ACI-2059-S15-2)
Always negotiate
Specifies rate negotiation with other copper Ethernet devices:
Checked (default): The switch automatically negotiates with
other copper Ethernet devices. APCON recommends that you
do not change this setting without first contacting support.
For contact information, see Contacting APCON on page 4.
Unchecked: The switch does not negotiate with other copper
Ethernet devices.
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Description
Specifies rate matching:
Unchecked (default): The switch does not match rates.
Checked: The switch automatically matches the rate at both
ends of the connection.
Note: Rate matching may get “stuck” if performing switch-toswitch hopping. For example, when multiple APCON switches are
arranged in a matrix configuration.
Specifies non-patched behavior:
Unchecked (default): Ports receive power only when
patched. This matches the operation of older INTELLAPATCH
switches and can be used to simulate a cable break.

LoS Passthrough

Checked: Ports always receive power, whether patched or
unpatched. This matches the operation of most
contemporary hubs, switches and routers. Although the port
indicates a linked status, it does not indicate whether the port
receives data.
When you select this option, you must also set Automatic
Transmitter disable to one of the TX off when no RX options.
For details, see Automatic Transmitter disable on page 139.
Determines how to handle Loss of Signal (LoS) on one side of a
pair of duplex-patched ports:
Unchecked: The continuity light on the INTELLAPATCH port the
device is patched remains lit. The device the port is patched
to may be dead, alive, or simply unpatched, but the port is
still “up” (powered and lit).

Temperature/Power
Audible alarms
enabled

Checked: The INTELLAPATCH switch forces the other side of
that pair to go offline.
Note: This option available only when transmitter disable is set to
one of the “TX off” states.
Options in this section specify temperature and power behavior.
Specifies the operation mode of the audible alarm.
Checked (default): The switch emits an audible alarm upon
reaching and/or exceeding the alarm threshold, or when a
power supply fails.

Unchecked: The switch does not emit an audible alarm
during an alarm condition. Other alarm notifications, such as
LEDs changing color, continue to operate.
For information about what comprises an alarm condition, see the
Temperature and Power options in Controller on page 78.
Intelligent fan control Determines the operation of fans inside the switch:
Unchecked (default): Fans operate at full speed all the time.

Temperature upper
limit

A54-3000-100 A

Checked: Fans operate at a rate appropriate for the blades
that populate the switch.
Specifies the temperature at or beyond which the switch triggers
an alarm. The default is 50° C.
WARNING: Enter a value of 55° or less. Temperatures above
55° C can damage the switch.
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Field
Port Behavior
Automatic
Transmitter disable

Automatic SPAN
security

Loopback on
disconnect
Help
Save button

A54-3000-100 A

Chapter 10: Settings

Description
Options in this section specify port behavior.
Specifies the behavior of the transmitter on a port that does not
receive a signal:
• TX off when no RX (Default): The transmitter on a port is turned
off when the opposing port’s receiver does not have signal.
• TX on always on: The transceiver’s transmitter is turned on at
all times, regardless of whether the opposing port receives
signal.
Determines SPAN port support:
• Disabled (Insert S15-2 or S15-4 blade to enable): This switch
supports SPAN ports.
• Enabled: This switch does not support SPAN ports. Selecting
this option ensures that SPAN ports do not receive any traffic.
Notes:
• This is a display-only field; you cannot change its value.
• SPAN security requires additional configuration. For details
about setting up SPAN security, see Simplex Patching with
SPAN/Monitor Ports on page 13.
Determines port behavior when the patch is disconnected:
Unchecked (default): Turns ports off upon disconnect.
Checked: Loops ports back to themselves upon disconnect.
Hovering your cursor over this icon displays Help information
about the associated field.
Saves and implements the changes you specify.
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Login Message
Specifies the message of the day that displays on the The WEBX login screen and the
Controller screen.
To change the message of the day, select:
Settings>Switch>Login Message
This screen displays on the Canvas:
Figure 58. Message screen

Text box

Status indicator

System message saved

The screen includes these options:
Note
To make changes on this screen, your account must have Administrator permission
privileges. For details about permissions, see Permissions on page 112.
Field
Text box
Current message
stamped:
Remove Message And
Save button
Save button
Status indicator
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Description
Displays the message of the day. You use this box to change or
delete the system message.
Displays the time and date the system message was last
changed.
Deletes the current message, then saves the change. Clicking
this button means no system message displays.
Saves your changes. Clicking this button means the updated
system message displays.
Indicates the action taken by WEBX. Displays only after you click
one of the buttons at the bottom of the screen.
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Chapter 11

Help

Chapter 11

This chapter details the screens available from the Help menu:
For information about...
Go to this page...
About .......................................................................................................................... 142
Support ....................................................................................................................... 143
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About
To view information about your INTELLAPATCH chassis, its blades, and login activity, select:
Help>About
This screen displays on the Canvas:
Figure 59. About screen

The screen includes information you can use when contacting APCON technical support.
For information about contacting technical support, see Contacting APCON on page 4 or the
Help>Support menu option.
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Support
To quickly access contact information for APCON support, select:
Help>Support
This screen displays on the Canvas:
Figure 60. Support screen

The screen includes these options:
Field
Latest Firmware
Standard Phone
Support
Online Support
APCON Sales
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Description
Lists pertinent information about your INTELLAPATCH chassis and
provides a link where you can obtain firmward upgrades.
Provides phone contact information for APCON technical support.
Provides links to a troubleshooting questionnaire and email
address for APCON support
Lists hours of operation and contact information for APCON’s Sales
department.
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For information about...Go to this page...
Sample SysLog File ................................................................................................... 144
Import/Export File Formats ......................................................................................... 147
Export Users File Format ............................................................................................ 148

A.1.

Sample SysLog File
For information about setting up your switch to write events to a SysLog, see the Enable
Remote Syslog option in Service Properties on page 117.
Events written to a logfile include:

A.1.1.

•

Powering on or off a blade.

•

Patching or unpatching a port.

•

Naming a port.

•

Storing, recalling, naming, or getting the name of a preset configuration.

•

Setting the data rate, duplex setting, or MDI/MDIX status of a port.

•

Setting the TCP/IP parameters of the I NTELLAP ATCH switch.

•

Setting the device number of the INTELLA P ATCH switch.

•

Enabling or disabling the Telnet interface, or its secure (SSH) variant.

•

Enabling a remote SysLog file, or getting or setting the IP address of the computer to
which to write it.

•

Requiring secure logins.

•

Resetting the I NTELLAP ATCH switch to its factory defaults.

•

Specifying an event type(Facility) and importance (Severity). For details about available
choices, see the Facility/Severity option on the Event Log screen. For details about this
screen, see page 82.

Format
The messages consist of:
[date] [serverIP] [switchname] apcond/[service]: [action]|b:[blade]
p:[port] u:[user]@[IP] [string]

— OR —
[date] [serverIP] [switchname] apcond/[service]: [action]|b:[blade]
p:[port] u:[user]/[remoteIP]@[IP] [string]
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Parameters
[date]

The date in standard RFC 3164 format.

[serverIP The IP address of the A PCON switch.
[switchname]

The name of the A PCON switch.

[service] The service that this action came from .
[action]

An action string. Current action strings include:
Info

Core service startup/shutdown
System reboot requested

Security

Login/logout
Bad login
Zoning
RPC connection
RPC disconnect

Configuration change
Patch
Blade powerup/powerdown
Port flapping
Port rate change
Preset recall
Preset name change
Preset definition change
Port name change
Switch name change
Port class enable
Port class name change
Port class definition change
Port locking enable
Port lock
Port unlock
Alarm
Power supply n failure/all-clear
Chassis temperature failure/all-clear
SFP alarm/alarm all-clear
SFP temperature failure/all-clear
SFP transmit failure/all-clear
SFP receive failure/all-clear
SFP power failure
SFP power failure
TX fault corrected
[blade]

A single-character blade letter or 0 (zero).

[port]

The three-character port number or 0 (zero).

[user

The user that caused the action.

[remoteIP]

(If present) The IP address from which the user is connected (see example).
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The IP address from which the call was made (see example).
Note
If the service resides inside the A PCON switch, such as the web, telnet, or SSH
service, the IP address may be 127.0.0.1.

[string]

A.1.2.

An optional string related to the command.

Import/Export Settings File Format

Jun 15 17:04:51 10.1.104.2 ununquadium apcond/apcond: core service startup|b:0 p:0
u:nobody@127.0.0.0
Jun 15 17:05:17 10.1.104.2 ununquadium apcond/web: login|b:0 p:0
u:admin/10.1.2.56@127.0.0.0
Jun 15 17:21:28 10.1.104.2 ununquadium apcond/web: configuration change|b:0 p:0
u:admin/10.1.2.56@127.0.0.0 Set name of preset 16 to "Preset 16"
Jun 15 17:22:15 10.1.104.2 ununquadium apcond/web: patch|b:0 p:0
u:admin/10.1.2.56@127.0.0.0
Q:A06A05A07A08A08A07A09A10A10A09A11A12A12A11A13A14A14A13A15A16
B01B02B02B01B03A00B04A00B05B01B06B01B07B02B08B02B09A00B10A00B11A00B12A00B13A00B14A0
0B15A00C01C02C02C01C03A00C04A00C05A00C06A00C07A00C08A00C09A00C10A00C11A00C12A00C13
A00C14A00C15A00C16A00D01D02
Jun 15 17:22:16 10.1.104.2 ununquadium apcond/web: patch|b:0 p:0
u:admin/10.1.2.56@127.0.0.0
Q:D02D01D03D04D04D03D05D06D06D05D07D08D08D07D09D10D10D09D11D12
D12D11D13A00D14A00D15A00D16A00
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Import/Export File Formats
Examples of some of the export file formats, provided below, are truncated for brevity:
Figure 61. Sample file formats

Plain Text INI
[PortNames]
A01=ATTO 3300
A02=Emulex LP10000DC
A03=Emulex LP8000
A04=Emulex LP8000S
A05=JNI Z210
A06=JNI FCE-6410
A07=LSI 7207XP-LC
A08=LSI 449290
—lines deleted for brevity—
[PortAssignments]
A01=OFF
A02=D02
A03=OFF
A04=OFF
A05=D05
A06=OFF
A07=OFF
A08=D07
—lines deleted for brevity—
Name=Preset 1
A01=NC
A02=NC
A03=NC
A04=NC
A05=NC
A06=NC
A07=NC
A08=NC
—lines deleted for brevity—
HTML
port number port name
A01

ATT0 3300

A02

Emulex LP 10000DC

A03

Emulex LP8000

A04

Emulex LP8000S

A05

JNI Z210

A06

JNI FCE-6410

A07

LSI 7207XP-LC

A08

LSI 449290
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Comma Delimited

XML and Diagnostic XML
< allsettings>
“port number”,”port name”
<portnames>
“A01”,”ATTO 3300”
<port number="A01" name="ATTO 3300"/>
“A02”,”Emulex LP10000DC”
<port number="A02" name="Emulex LP100DC"/>
“A03”,”Emulex LP8000”
<port number="A03" name="Emulex LP8000"/>
<port number="A04" name="Emulex LP8000S"/>
“A04”,”Emulex LP8000S”
<port number="A05" name="JNI Z210"/>
“A05”,”JNI Z210”
<port number="A06" name="JNI FCE-6410"/>
“A06”,”JNI FCE-6410”
<port number="A07" name="LSI 7207XP-LC"/>
<port number="A08" name="LSI 449290"/>
“A07”,”LSI 7207XP-LC
—lines deleted for brevity—
“A08”,”LSI 449290”
</portnames>
“porta”,”portb”
<patches>
“A01”,”A12”
<patch porta="A01" portb="A00"/>
<patch porta="A02" portb="D02"/>
“A02”,”B05”
<patch porta="A03" portb="A00"/>
“A03”,”C01”
<patch porta="A04" portb="A00"/>
<patch porta="A05" portb="D05"/>
“A04”,”A05”
<patch porta="A06" portb="A00"/>
“A05”,”A04”
<patch porta="A07" portb="A00"/>
“A06”,”B11”
<patch porta="A08" portb="D07"/>
“A07”,”B12”
—lines deleted for brevity—
</patches>
“A08”,”C02”
<presets>
“preset”,”preset
<preset number="1" name="Preset 1">
name”,”porta”,”portb”
<patch porta="A01" portb="A99"/>
<patch porta="A02" portb="A99"/>
1,”Preset 1”,”A01,”A99”
<patch porta="A03" portb="A99"/>
1,”Preset 1”,”A02,”A99”
<patch porta="A04" portb="A99"/>
1,”Preset 1”,”A03,”A99”
<patch porta="A05" portb="A99"/>
<patch porta="A06" portb="A99"/>
1,”Preset 1”,”A04,”A99”
<patch porta="A07" portb="A99"/>
1,”Preset 1”,”A05,”A99”
<patch porta="A08" portb="A99"/>
1,”Preset 1”,”A06,”A99”
—lines deleted for brevity—
1,”Preset 1”,”A07,”A99”
</preset>
—lines deleted for brevity—
1,”Preset 1”,”A08,”A99”
</presets>
</allsettings>
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Export Users File Format
# User list export of 10.1.104.2 on 2007-12-06 20:33:09 UTC
# Format: <username>:<level>:<MD5 password hash>
# User level is: 1=guest, 2=basic, 3=advanced, 4=admin
drevil:4:A94FA805F98ECA6FE686930C7C8B0403
number2:3:27BF0058AF50FD43E46419D6324F0B88
minime:1:1A242DA32316B0F62E406A95E7DB2DE9
scott:2:21F63C6E971CD913A9C147E8652CA659
basil:3:6862EFB4028E93AC23A6F90A9055BAE8
bigglesworth:1:CC7F3896E15C5628A175484C088C5D24

The # Format: line includes these fields:
Field
username

level

MD5 password hash
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Description
Specifies the new account name. Account names are not
case-sensitive. Account names can include underscores or
hyphens, but cannot include spaces or special characters.
Specifies the permission, or access level, for each user:
1
Guest: Users with this permission level have read-only
access. This is the lowest permission level.
2
Operator: Users with this permission level can do all that
Guest-level users can do, plus patch ports using only preset
configurations.
3
Advanced Operator: Users with this permission level can do
all that Basic Operator-level users can do, plus patch ports
on an ad-hoc basis, change rates and port names, plus
save configuration settings (“presets”).
4
Administrator: Users with this permission level do
everything that the other levels do, plus set switch, blade,
port, and other information as well as set and clear user and
security information. This is the highest permission level.
The MD5 hash of the user password.
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Adding APCON Attributes to
your RADIUS Server

Appendix B

After you finish the initial setup, verify that it works. You can then add attributes, which are
available to the A PCON firmware that supports them.
Note
Examples of the of the RADIUS attributes are based on the FreeRADIUS server. The exact
syntax depends upon your RADIUS server.
To add attributes:
1.

Get the dictionary.apcon file from support (Professional Services).

2.

Copy dictionary.apcon to this location:
/usr/share/freeradius/

3.

Edit /etc/raddb/dictionary, adding this line:
$INCLUDE /usr/share/freeradius/dictionary.apcon

This adds an Apcon-User-Level attribute with these possible values:

4.

0

Default

User inherits the switch’s default new user level.

1

Guest

User has read-only access.

2

Operator

User has some pre-canned write functionality (for example, recalling
presets).

3

Advanced

User can perform ad-hoc patching.

4

Admin

User can administer the switch.

Alter the user lines /etc/raddb/users to include the user level. For example:
user1 Auth-Type := Local, User-Password == “pass1”
Apcon-User-Level == Admin

5.

Restart your RADIUS server by entering this command:
sudo /etc/rc.d/init.d/radiusd restart
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Overview
The A PCON switch supports up to three TACACS+ servers. The A PCON switch does not
allowing the server to redirect the switch to a different server, possibly using a different
protocol.
TACACS+ provides authentication (user identity verification) and authorization (switch
access levels ). Accounting provides an audit trail of who logged in, who logged out and who
made configuration changes to the switch, and is provided though the syslog.
TACACS+ can provide authorization on a per-switch basis. (Zoning provides authorization on
a per-port basis.)
The A PCON switch requests password authentication while the server handles user
authentication. It can use the system password file or store the user's password in any form it
desires. If the TACACS+ sever doesn’t recognize a user or the user’s login has expired,
access is denied to that user. If the server recognizes a user but doesn't have an explicit
A PCON user level, the user receives the system default.

C.2.

Configuring The Server
Note
Examples of the of the TACACS+ server configuration file are based on the references
server in the TAC_PLUS Developer’s Kit from Sysco Systems, Inc. The exact syntax
depends upon your TACACS+ server.

C.2.1.

Setting the Shared Secret
The shared secret is identified by the line "key = ". The value inside of quotes appears on
the shared secret line of the input file for tacpluslogin. This can be any value, but it must
match exactly in case and white space.
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The next figure shows how to set the shared secret on the A PCON switch on the left. On the
right, is a snippet of the server’s configuration file. The second TACACS+ server would have
a similar file.
Figure 62. Setting up the shared secret

Setting the shared secret on
the A PCON switch via
Configuration>User Database
(described on page 107)

Configuration file for
first TACACS+ server

key = “Secret #1”
group = guest {
service = shell{}
cmd = apcon_guest {
permit .*
}
}

In the Server Configuration file example below, the A PCON switch is set via the console, but
any user with administrator rights can use any connection. If the change is from a connection
other than the console, the user will likely need to log in after changing to the TACACS+
database.
Note
Although double quotes aren’t used around the shared secret on the A PCON switch, the
double quotes may be needed in the configuration file.
console>> configure userauthentication
Authentication Method? [N]one, [I]nternal, [R]ADIUS, [T]ACACS+ [n/i/r/T/?]: T
TACACS+ servers:
Server 1
IP Address? [10.1.108.0]:
Shared Secret? [old]: Secret #1
<-> key = "Secret #1"
Enable a second server? [Y/n] Y
Server 2
IP Address? [10.1.100.50]:
Shared Secret? [old]: Secret #2
Enable a third server? [y/N] N
If server responds with no level? [D]eny access, [G]uest, [O]perator,
ad[V]anced, [A]dministrator [D/g/o/v/a]: D
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Apcon Access Levels and Service
You can assign these access levels to a user or group of users:
•

apcon_admin

•

apcon_adv

•

apcon_basic

•

apcon_guest

The server is configured to allow authorization for the user for the service shell and one of
the A PCON levels as a cmd.

C.2.3.

Assigning Authorization
For information about...
Go to this page...
User Authorization ...................................................................................................... 152
Group Authorization ................................................................................................... 152
A PCON Switch Authorization ........................................................................................ 153
Unspecified Authorization ........................................................................................... 154

11.2.0.1.

User Authorization
The most basic configuration is assigning access levels directly to a user. This snippet of the
TACACS+ Server Configuration file assigns advanced access to the user clark for all
A PCON switches:
user = clark {
service = shell {}
login = cleartext "clark-pw"
cmd = apcon_adv {
permit .*
}
}

11.2.0.2.

Group Authorization
The server likely supports users and groups belonging to groups. If a right isn’t specified for
a user or group, the server looks in groups that user or group belongs to.
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This snippet of the TACACS+ Server Configuration file includes apcon permission in the
group description:
group = user {
service = shell {}
cmd = apcon_basic {
permit .*
}
}
user = lois {
login = des 5EFj8xcpfXY8U
member = user
}
user = jimmy {
login = cleartext "jimmy-pw"
member = user
}

11.2.0.3.

A PCON Switch Authorization
You can use the permit and deny attributes to assign different authorization levels on
different switches.
This snippet of TACACS+ Server Configuration file defines access for the user phineas:
group = user {
service = shell {}
cmd = apcon_basic {
permit .*
}
}
user = phineas {
service = shell {}
login = cleartext "phineas-pw"
cmd = apcon_admin {
permit 10\.1\.108\.0
}
cmd = apcon_adv {
permit 10\.1\.108\.[0-9]*
}
member = user
}

The code defines the following access for phineas:
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•

Administrator access on the A PCON switch with a primary IP address of 10.1.108.0.

•

Advanced access on any other A PCON switch with a 10.1.108.* primary IP address.

•

Basic access on any other A PCON switch, as a member of the user group.
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Unspecified Authorization
If a user is in the TACACS+ database but doesn’t have an assigned A PCON authorization
level, that user receives the switch default. The default can deny access or assign the user a
level, from guest to demonstrators.
You can set default action set to deny access using either of these:
•

WEBX
Figure 62. Setting up the shared secret

•

Command line interface
Six Corners>> configure userauthentication
Authentication Method? [N]one, [I]nternal, [R]ADIUS, [T]ACACS+ [n/I/r/t/?]: T
TACACS+ servers:
Server 1
IP Address? [10.1.108.0]:
Shared Secret? [Secret #1]:
Enable a second server? [Y/n] N
If server responds with no level? [D]eny access, [G]uest,
[O]perator,ad[V]anced, [A]dministrator [D/g/o/v/a]: D
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Accounting
The syslog handles the accounting or audit trail. You can configure the A PCON switch to send
audit event to up to three syslog servers.
By default, the messages from A PCON switches are placed into /var/log/messages on the
server(s). You can then redirect these messages either to a file specific to A PCON switches or
the file used by the TACACS+ server.

C.3.1.

Example: Routing Messages To TACACS+ Log
The next example redirects the messages to the TACACS+ server file. It assumes the
TACACS+ server is configured to send its messages to /var/log/tacacs.
The syslog log redirects messages by service. All messages for a given service that exceed
the specified threshold are rerouted to the file. The local6 service was chosen because it
unused on the local network. Your choice depends on services used by your network and
supported by your syslog server.
Note
The syslog configuration syntax and location of files depends on the operating system and
syslog on your servers. The server used in this example is the default syslog server running
on Fedora 6 Linux.
Add the following two lines to /etc/syslog.conf on your servers.
# Route messages from Apcon switch
local6.=notice
/var/log/tacacs

This causes the message from service local6 and a severity exactly matching notice to be
sent to /var/log/tacacs. You must send a HUP signal to the syslog server so it will reread its
configuration file.
You must configure the A PCON switches to match the servers.You can configure APCON
switches using either of these:
•

Command line: The next example shows the syslog being configured from the command
line interface. Typing a "?" for facility and severity displays the possible values.
Note
The exact command syntax and file location depends on the version of syslog your
server is running.
Six Corners>> configure service syslog
syslog servers:
Server 1
IP Address? [10.1.108.0]:
Enable a second server? [Y/n] Y
Server 2
IP Address? [10.1.100.50]:
Enable a third server? [y/N] N
Facility? [22] (? for help): 22
Severity? [5] (? for help): 5
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WEBX: This shows syslog on the A PCON switch being configured to match the server
above. The facility and severity are set to match the server. You access this screen by
selecting Configure>Services.
Figure 63. Configuring the syslog to match syslog server
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Index
A

certificates
generating SSH 126., 127.
generating SSL 125.
Chassis
Controller Status 78.
Event Log 82.
Logged In 84.
Show Toolbar checkbox 85.
Toolbar Text Labels checkbox 85.
chassis model, viewing 78.
checkbox options
Show Toolbar checkbox 85.
Toolbar Text Labels checkbox 85.
classes
analyzer 13.
backpatch 13.
Classes screen 65.
SPAN 13.
Classes screen 65.
comma delimited log files 147.
Configuration
Classes 65.
Edit Presets 75.
Names 63.
Zoning 70.
configuration settings, export 93.
configuration settings, import 82., 97.
configuration, reset to factory defaults 100.
configure patches
preset configurations 45., 46.
Connections options
Patching
Batch 37.
By Name 42.
By Preset 45., 46.
Realtime 33.
View Patches 47.
contacting APCON 4.
Controller Status screen 78.
CONTROLX software 4.

About screen 142.
accessing the WebX interface 23.
administrator, using default account 24.
advanced (simplex) data flow 36., 41., 43.
alarm, viewing status 80.
Alarms screen (SFP/XFP) 61.
analyzer class 13.
analyzers, SPAN/monitor ports 13.
APCON
C/C++ API 4.
contacting 4.
CONTROLX software 4.
Firmware Direct Commands software 4.
MONITOR software 4.
technical support, contacting 143.
ASCII command set interface 4.
ASCII commands over network, enabling 118.

B
backpatching 13.
Backup Settings screen 93.
Backup Users screen 96.
Backup/Restore
Backup Settings 93.
Backup Users 96.
Restore Settings 97.
Batch screen 37.
blade power, setting 59.
Blades
ACI-S15-2 13.
ACI-S15-4 13.
Power 59.
Properties 57.
By Name dialog box 43.
By Name screen 42.
By Preset screen 45., 46.

C
C/C++ API 4.
Cable Test screen 87.
Canvas 8.
Certificates
screen 125.
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simplex (advanced) 36., 41., 43.
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data rate, select 52.
database, users 107.
Date/Time screen 131.
device number, verifying 79.
Diagnostics
Cable Test 87.
Flapping 89.
Signal Counters 91.
duplex (normal) data flow 36., 41., 43.

T

U V W X

Edit Presets screen 75.
Ethernet
assign IP address to connect to 17.
cable type 18.
Event Log screen 82.
exiting the WebX interface 31.
exporting configuration settings 93.

License Key screen 98.
Local Users screen 110.
Locks screen 54.
log file
comma delimited format 147.
HTML format 147.
plain text format 147.
samples 147.
XML format 147.
Logged In screen 84.
logging in 23.
logging out 31.
login
names, adding 111.
password 23.
user name 23.
Login Message screen 140.
loopback signal 13.

F

M

E

Z

Maintenance options
Backup/Restore
Backup Settings 93.
Backup Users 96.
Restore Settings 97.
Switch
License Key 98.
Reset 99.
Upgrade Firmware 101.
manufacture date, viewing 79.
MIB file 122.
MONITOR software 4.
motherboard model, viewing 78.
mouse techniques 8.

features, configuring 98.
features, WebX 9.
files
MIB 122.
Firmware Direct Commands 4.
firmware version, verifying 79.
Flapping screen 89.
forcing secure logins 118.

G
gateway, verifying 79.

H
hardware information, viewing 78.
Help options
About 142.
Support 143.
help, getting 4.
HTML log files 147.

N
Names screen 63.
navigation techniques 8.
network parameters, configuring 129.
new users, adding 111.
normal (duplex) data flow 36., 41., 43.
numbering, ports 63.

I
import configuration settings 82., 97.
IP address
assigning 17.
verifying 79.

P
panes
Content 8.
parameters, network 129.
password 23.
changing 65., 67., 104., 125.
changing, SNMP v3 114.

L
labeling switches 9.
labeling, switch 9.
LAN Interface screen 129.
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patches
editing 75.
preset configurations 45., 46.
presets 75.
view current 47.
view current settings 57.
Permissions screen 112.
Personalization
Your Password 104.
Your Preferences 105.
plain text, log files 147.
Port Properties screen 50.
Ports
Locks 54.
Port Properties 50.
Rates 52.
ports
naming 63.
secure 13.
Ports/Blades options
Blades
Power 59.
Properties 57.
Configuration
Classes 65.
Edit Presets 75.
Names 63.
Zoning 70.
Ports
Locks 54.
Port Properties 50.
Rates 52.
SFP/XFP
Alarms 61.
Properties (SFP/XFP) 60.
power
setting 59.
verifying 80.
Power screen 59.
power supply alarm, viewing status 80.
preferences
changing 105.
preset patch configurations
setting 45., 46.
presets
editing 75.
Properties (blades) screen 57.
Properties (SFP/XFP) screen 60.
Properties (switch) screen 133.
proxy server 18., 21.
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RADIUS server 11.
rate, set data transmission 52.
Rates screen 52.
Realtime screen 33.
rebooting the switch 99.
reset configuration 100.
Reset screen 99.
Restore Settings screen 97.
RPC, enabling 120.

S
screens
About (Help) 142.
Alarms (SFP/XFP) 61.
Backup Settings 93.
Backup Users 96.
Cable Test 87.
Certificates 125.
Classes 65.
Controller Status 78.
Date/Time 131.
Event Log 82.
Flapping 89.
LAN Interface 129.
License Key 98.
Local Users 110.
Locks 54.
Logged In 84.
Login Message 140.
Names 63.
Permissions 112., 114.
Port Properties 50.
Power 59.
Presets 45., 46.
Properties (blades) 57.
Properties (SFP/XFP) 60.
Properties (switch) 133.
Rates 52.
Reset 99.
Restore Settings 97.
Service Properties 117.
Signal Counters 91.
SNMP 122.
Support (Help) 143.
Upgrade 101.
User Database 107.
Your Password 104.
Your Preferences 105.
Zoning 70.
Secure port 13.
security, managing 117.
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serial ID 50.
serial number, viewing 78.
Service Properties screen 117.
Services
Certificates 125.
Service Properties 117.
SNMP Properties 122.
setting patches
by name 42.
in batches 37.
modifying 75.
realtime 33.
Settings
Switch
Date/Time 131.
Settings options
Personalization
Your Password 104.
Your Preferences 105.
Services
Certificates 125.
Service Properties 117.
SNMP Properties 122.
Switch
LAN Interface 129.
Login Message 140.
Properties 133.
Users/Security
Local Users 110.
Permissions 112.
SNMP v3 Users 114.
User Database 107.
settings, view current 57.
Setup
User Authentication 11.
SFP/XFP
Alarms 61.
Properties (SFP/XFP) 60.
Show Toolbar checkbox 85.
Signal Counters screen 91.
simplex (advanced) data flow 36., 41., 43.
simultaneous ASCII commands, enabling 118.
slash commands over network, enabling 118.
slot power, setting 59.
SNMP Properties screen 122.
SNMP v3 Users screen 114.
SNMP, enabling 120.
software
ASCII command set 4.
C/C++ API 4.
Firmware Direct Commands 4.
Monitor 4.
Telnet command-line interface 4.
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SPAN class 13.
SPAN/monitor port sharing with analyzers 13.
SSH certificate, generating 126., 127.
SSL certificate, generating 125.
subnet mask, verifying 79.
Support screen 143.
Switch
Date/Time 131.
LAN Interface 129.
License Key 98.
Login Message 140.
Properties 133.
Reset 99.
Upgrade Firmware 101.
switch
characteristics, setting 133.
exporting settings 93.
importing settings 82., 97.
labeling 9.
manufacture date, viewing 79.
name, viewing 79., 81.
rebooting 99.
settings, viewing 78.

T
TACACS+ server 11.
Telnet command-line interface 4.
telnet session
enabling 119.
temperature, viewing status 80.
TFTP session, enabling 120.
Toolbar Text Labels checkbox 85.
Tools options
Diagnostics
Cable Test 87.
Flapping 89.
Signal Counters 91.
transceiver details, view 50.
transmission rate, set 52.
troubleshooting 4., 98., 99.

U
updating switch firmware 101.
Upgrade Firmware screen 101.
URLs, Apcon 4.
user accounts, managing 107., 110., 112.
User Authentication servers
Internal 11.
RADIUS 11.
TACACS+ 11.
User Database screen 107.
user name 23.
users
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adding 111.
Users/Security
Local Users 110.
Permissions 112., 114.
User Database 107.

U V W X

Y

Z

W
WebX Interface features 9.
World-Wide Web URLs, Apcon 4.

X
XML log files 147.

V
View options
Chassis
Controller Status 78.
Event Log 82.
Logged In 84.
Show Toolbar checkbox 85.
Toolbar Text Labels checkbox 85.
View Patches screen 47.
viewing switch information 78.
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Your Password screen 104.
Your Preferences screen 105.

Z
Zoning screen 70.
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